Has anyone used Dutchman Good or Bad

Old 04-07-2010, 07:05 AM
  #1  
Billydo
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Oct 2009
Posts: 2
Default Has anyone used Dutchman Good or Bad

I have Dutchman axles in the housing of my nova it is a ford 9in 35 spline I was going to get a Dutchman 3er member but I am looking for some feed back on there quality and reliabilty, just trying to match all components
Billydo is offline  
Old 04-07-2010, 11:08 AM
  #2  
mytmouz
Senior Member
RACING JUNKIE
 
mytmouz's Avatar
 
Join Date: May 2006
Location: Pelahatchie, MS
Posts: 996
Default

I have a set in my street ride, and I have had them in the past on other stuff. (Already in them when I got them) No problems with anything...
mytmouz is offline  
Old 04-07-2010, 11:58 AM
  #3  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

I had a set in my ol '63 Nova with a 9". I probably put 1500+ 1/4 mile runs on them running high 10's low 11's and never had an issue. They were still in it when I sold the car....
Johnny
johnracer is offline  
Old 04-08-2010, 09:38 AM
  #4  
Billydo
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Oct 2009
Posts: 2
Default

Cool thanks for your help, I think I will go ahead order from them a new 3rd member
Billydo is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service