Car slowed down 2 tenths..Advice?

Old 11-15-2014, 03:59 PM
  #1  
racerrob1220
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Nov 2014
Posts: 1
Default Car slowed down 2 tenths..Advice?

I have a 1982 Malibu Wagon with a 350 ZZ4 crate motor and a power glide trans. Converter unknown but stalls at around 3900.
I shift it at 6400rpms and it goes through the 1/4 mile at around 6400 to 6600rpm depending on the weather. And 60' around 1.70. And has run the best of a 11.72 @115mph.

Last few times out with the car it has been slowing down. And the last time out it was like 2 tenths slow of what it should have been running. And was very inconstant. It varied from .03 to .19 in seven passes.

The 60 foots are about 4 slow and its only finishing at 6000rpms.
so something has gone away. I have already checked a few things and have a idea of what it could be but wanted other options before I do a lot of work for nothing..

Thanks for your help on this.........Rob Derr
racerrob1220 is offline  
Old 11-17-2014, 07:15 PM
  #2  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Converter or trans .....hows the fluid smell ?
TheYellaBrick is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service