Powerglide / convertor questions..

Old 09-25-2014, 04:40 AM
  #1  
lodilobo
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 35
Default Powerglide / convertor questions..

I'm trying to help a friend out, but based on the info I have, I'm not sure, so I need to ask for opinions. Camaro, 1979 355 motor, built pretty good. I estimate 420 - 460 h.p. P.G. w/ trans brake, and 4000 stall convertor. Here are the symptoms....with the car staged, on the line, using the trans brake, or the foot brake, rpm will not go beyond 4500. When the car leaves, it seems to be restricted, until it gets out about 500 ft., then starts running strong. Here is what has been done to this point....changed carbs...changed convertors 3 times....changed ignition coil...adjusted valves. I got involved after most of this stuff had been done. Up until recently, I was convinced it was in the motor...now I'm not so sure. The motor doesn't misfire, or break up. In fact, it seems to run strong. The ignition box is an older 7AL....the distributor is an older MSD with centrifugal advance. I have it timed AT 38 degrees. My next step will be to lock the distributor, or switch to a crank trigger system. It's a wierd situation. The owner has had this problem since the engine was installed, with the exception of one pass, when the car left strong and posted an e.t. a full second quicker than current times. Any suggestion will be appreciated.
lodilobo is offline  
Old 09-25-2014, 06:57 AM
  #2  
shawnp
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Ohio
Posts: 937
Default

Which 7al box? Start retard or timing retard that may be acting up? Timing may be moving period with the distirbutor. If they have tried 3 different converters now and the car acts the same way, I would be leaning toward an electrical issue and then looking at a fuel issue.
shawnp is offline  
Old 09-25-2014, 08:11 AM
  #3  
lodilobo
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 35
Default

I'm thinking that distributor is the culprit. I've had convertor problems before, but never a situation where it would hold the rpm back. Thanks for the reply.
lodilobo is offline  
Old 06-28-2015, 10:16 AM
  #4  
seefour
Junior Member
SHOW GUEST
 
Join Date: Jun 2015
Posts: 1
Default

Is the motor extremely fat? It might take that long to burn unused fuel then take off.
seefour is offline  
Old 07-05-2015, 03:40 PM
  #5  
luckey
Junior Member
SHOW GUEST
 
Join Date: Nov 2003
Posts: 2
Default

low trans fluid,band set incorrectly,fluid pressure too low. Make sure the linkage is not hanging between low and drive.
luckey is offline  
Old 05-14-2016, 08:25 AM
  #6  
hardatach01
Junior Member
SHOW GUEST
 
Join Date: May 2016
Posts: 9
Default

For one thing I think you have too much timing in it. I was told once (after torching a head between 3 and 5) that if you went over 36 degrees you were risking engine damage. Also it sounds like you may have rolled the sprag in your converter, ( but you have tried 3 different converters) so that probably isn't the problem. If it looks like the advance is coming in right in your distributor, then I would not think that it would be a distrib. problem. The timing issue, 38 degrees would make it run faster on the bottom, and lay down on top. I think I would look into the 7AL box if I were you. also if the cam is not in right that could cause your problem. Sounds like maybe too much advance in the cam. Those are the two (box and cam) that I would look into. Just my two pennies.
hardatach01 is offline  
Old 12-17-2017, 09:16 AM
  #7  
KevinJRoche
Junior Member
SHOW GUEST
 
Join Date: Dec 2017
Posts: 1
Default EngineMasters Machine Shop Owner

If the Driveline Diameter is too small for the Length of the Shaft and 500HP, if its over 48" x .065" tubing(u-joint to u-joint) should have 3"dia. x .083" tubing up to 48" and tubing 3 1/2" x .083" DOM tubing to prevent from winding up, loosing the centerline from pinion yoke angle to trans yoke angle will bind u-joints. Should have 1 1/2 to 2 1/2 interference angle between trans and pinion for u-joints to work properly. Over 53" length should have 4" diameter tubing. If 500HP+ or go with a carbon fiber driveshaft and back off the brakes.
KevinJRoche is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service