BBC BLOCK W/ O RINGS, ANY HEAD GASKET BESIDES COPPER?

Old 02-20-2014, 08:27 PM
  #1  
bowler
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2006
Posts: 103
Default BBC BLOCK W/ O RINGS, ANY HEAD GASKET BESIDES COPPER?

I HAVE A BBC 454 BLOCK BORED .100 OVER THAT HAS SS O RINGS, IS THERE A HEAD GASKET OTHER THAN COPPER, I READ THAT YOU COULD USE A COMPOSITE HEAD GASKET? (ALUMINUM HEADS), ANY IDEA HOW TO REMOVE THE O RINGS FROM THE BLOCK?. THANKS DOUG
bowler is offline  
Old 02-21-2014, 09:48 AM
  #2  
oldandtired
Senior Member
RACING JUNKIE
 
oldandtired's Avatar
 
Join Date: Dec 2008
Location: Sugar Hill, GA
Posts: 1,370
Default

Are you naturally aspirated or running nitrus or forced induction?
oldandtired is offline  
Old 02-21-2014, 11:13 AM
  #3  
curtisreed
Senior Member
RACING JUNKIE
 
curtisreed's Avatar
 
Join Date: Feb 2004
Location: KIEFER, OK.
Posts: 1,311
Default

Doug, I believe the options you have are: deck the block to get rid of the o-ring groove, put copper wire in and pound it flat , see if the ring on the std. head gasket you want to use will seal up with just the groove, or run copper gaskets.

I would probably just run copper gaskets if it were mine, but I haven't run them before. You might PM Zipper on here. He runs blown combos and probably has as much experience as anyone on here with o-rings.

Curtis
curtisreed is offline  
Old 02-21-2014, 02:56 PM
  #4  
bowler
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2006
Posts: 103
Default

Dave i bought this engine the block is a old ls7 block, i run a single dominator, 14 to 1, on gas, had copper head gaskets on it with copper coat, i just pulled the heads & sent them to hrd head service to have them ported & looked like 1 chamber had some water, Curtis i don't want to deck the block i would like to be able to pull the ss o rings out of the block but have had no luck removing them, worst case i will use the copper head gaskets & silicone around the water jackets? thanks for the help Doug
bowler is offline  
Old 02-21-2014, 04:53 PM
  #5  
mytmouz
Senior Member
RACING JUNKIE
 
mytmouz's Avatar
 
Join Date: May 2006
Location: Pelahatchie, MS
Posts: 996
Default

Usually the leakage with the copper head gaskets are around the studs or bolts. I would seal those and swap the heads around to see if the problem moves...
mytmouz is offline  
Old 02-21-2014, 05:21 PM
  #6  
bowler
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2006
Posts: 103
Default

These were bolts and I used Right Stuff on the threads, the 1 chamber had little white deposits around the chamber not sure if it was water? the rest looked good, Curtis I sent the Patriot heads to Al Dicksen (rhd) he called & said the valves were terrible as were the chambers & seats!! so when I get them back (new valves & 2.30 intakes) he said I should pickup at least 3 tenths which would get me in the 8.90's hope he is right!, Doug
bowler is offline  
Old 02-21-2014, 05:32 PM
  #7  
curtisreed
Senior Member
RACING JUNKIE
 
curtisreed's Avatar
 
Join Date: Feb 2004
Location: KIEFER, OK.
Posts: 1,311
Default

That would be awesome. I'm going to have to slow my car down because it won't certify and they are going to clamp down on that stuff. Back to 10.0 from 9.40s for me. I'm machining up one of the removable restrictor plate to race some 10.50 index stuff also.
curtisreed is offline  
Old 02-21-2014, 06:46 PM
  #8  
zipper06
Senior Member
RACING JUNKIE
 
Join Date: Jan 2006
Location: La.
Posts: 2,890
Default

Originally Posted by bowler
These were bolts and I used Right Stuff on the threads, the 1 chamber had little white deposits around the chamber not sure if it was water? the rest looked good, Curtis I sent the Patriot heads to Al Dicksen (rhd) he called & said the valves were terrible as were the chambers & seats!! so when I get them back (new valves & 2.30 intakes) he said I should pickup at least 3 tenths which would get me in the 8.90's hope he is right!, Doug
Doug, there's absolutely nothing wrong with copper head gaskets, i prefer them to any other gaskets, even cosmetic, you can buy 4.380 X .043 gaskets from Summit for $92.00, i just use a spray sealer on the gaskets and let them set for a couple hrs. before installing them, they are really the only option with O'ring wire installed. In fact Summit says on these gasket you muct have O'rings it the block. Onn the blower motor i use the coper gaskets with o;rings in them rather than O'ringing the block and i push more than 30 lbs boost on a sm/blk.

JMO

Zip.
zipper06 is offline  
Old 02-22-2014, 08:21 AM
  #9  
coloradoracerguy
Senior Member
SENIOR BUILDER
 
Join Date: Dec 2007
Location: Morrison, Colorado
Posts: 120
Default

What shape are the decks in? Mine leaked a bit of water, and it was due to the decks overall condition. Here's what I'd do. Have a machine shop that's got the proper capability to o-ring blocks pull the wire out, clean up the decks, and recut the grooves. Install new wire and keep running the copper gaskets. Make sure your heads are cut to match with receiver grooves, the gasket that's being pushed up by the o-rings needs a place to go, and can keep the head from sitting flat. Spray the gaskets with a couple of good coats of copper coat, and let it dry between coats. Make sure the heads and deck are clean and dry, and your head studs are sealed with either silicone, or another non hardening sealer, NOT TEFLON TAPE OR PASTE. Teflon will wash out. You can use loctite, but good luck getting the studs out again if you need too...Then just assemble them like normal, bring it up to full operating temp, let it cool down, and retorque. One big thing that not many think of here is make sure that the torque wrench you're using is accurate!!! The higher the torque the more the error, and if your wrench hasn't been calibrated in a while, or is a cheaper model, you may not be getting the PROPER torque on your studs, and that means less clamping force, less compression, and less sealing! Lastly, you can use a VERY SMALL AMOUNT of hylomar or other AUTOMOTIVE GRADE silicone around the coolant passages instead of the copper coat, but it has to be very thin or it could possibly either block the smaller holes or keep the gasket from sitting down all the way...Had it happen to me before, no fun to fix at the track.....
coloradoracerguy is offline  
Old 02-22-2014, 10:22 AM
  #10  
bowler
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2006
Posts: 103
Default

Zip and Mark thanks again for your help, yep I did use a cheap torque wrench with bolts (came with arp bolts), the one thing that I did not do was re-torque!, only reason that I pulled the heads was to have them ported and all looked good except 1 chamber (white specs), I will call Al about cutting receiver grooves in the heads. Thanks again Doug
bowler is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service