slide-a-link

Old 12-31-2013, 05:44 PM
  #1  
Eddie12008
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Dec 1969
Posts: 1
Default slide-a-link

I have a 1978 Camaro. Does the spring pad bolt straight to the spring or on the stock rubber pad on a slide-a-link traction bar
Eddie12008 is offline  
Old 12-31-2013, 05:57 PM
  #2  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 628
Default

I am running a slide a link on my nova I can't remember how it's bolted. I will try to look in the next couple days and let you know.
Swiley383 is offline  
Old 01-15-2014, 10:13 AM
  #3  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 628
Default

I have not had a chance to look yet been busy I will try this weekend.
Swiley383 is offline  
Old 01-15-2014, 04:07 PM
  #4  
Swiley383
Senior Member
RACING JUNKIE
 
Swiley383's Avatar
 
Join Date: Apr 2010
Location: White Bluff TN
Posts: 628
Default

I just looked mine are bolted with the rubber pad between the slide a link and the spring hope this helps you out. My car is a 74 nova so the springs should be similar.
Swiley383 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -