marauder battery light on... Ford guys tech support

Old 07-13-2013, 04:02 PM
  #1  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default marauder battery light on... Ford guys tech support

Hi guys
Battery light appears on my dash on my 03 marauder 4.6 liter..The factory volt gauge reads 10 volts, my meter reads 10.3 volts running, shut the car off the battery voltage jumps to 11.5 v. So I say alternator, buy one on line New not reman. install it today. The inside voltage gauge reads 14 and so does mine 14.1. Alls good right, wrong, you start the car,no battery light till about 2 mins later,... any ideas, the car cranks over fast and starts all the time, possibly a bad alt out of the box ?????
bixblk is offline  
Old 07-13-2013, 04:57 PM
  #2  
fla1976
Senior Member
RACING JUNKIE
 
fla1976's Avatar
 
Join Date: Aug 2007
Posts: 1,536
Default

Did you charge the battery before installing the alternator? A low battery can burn up a new alternator because it is not a battery charger. An alternator is designed to maintain a battery. A low battery can overwork the alternator.
fla1976 is offline  
Old 07-13-2013, 05:03 PM
  #3  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default battery

the battery voltage was 11.5 when I removed the cables to install the alt, I did charge the battery @ first, so I did not charge it awhile after the battery light went on. only about 20 mins
Thanks
bixblk is offline  
Old 07-13-2013, 07:43 PM
  #4  
fast75vega
Senior Member
RACING JUNKIE
 
Join Date: Nov 2008
Location: Niagara Falls, NY
Posts: 965
Default Re: battery

Originally Posted by bixblk
the battery voltage was 11.5 when I removed the cables to install the alt, I did charge the battery @ first, so I did not charge it awhile after the battery light went on. only about 20 mins
Thanks
11.5 is a low battery... gotta make sure your battery isnt bad cause bad/loose lead plates can cause the same problem. battery should always be around 12 1/2 volts or more and around 14volts at idle.
fast75vega is offline  
Old 07-13-2013, 08:14 PM
  #5  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default battery light

I will install my spare chevelle battery that is a fully charged ( known good) and ready to go, that will tell me if the battery is bad, thanks for the tech support.
bixblk is offline  
Old 07-14-2013, 09:18 AM
  #6  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default light

I put a battery in the car, used but known good,same problem. I did charge the current battery in the car, it now reads 12.4 v and when I run the alt at idle its 14.1. and it also kicks on the battery light still. gonna clean up the grounds and see what happens ????
bixblk is offline  
Old 07-14-2013, 04:26 PM
  #7  
wazup
Senior Member
EXPERT BUILDER
 
Join Date: Dec 2010
Posts: 345
Default

Check the fuses as the computer controls the alt.
wazup is offline  
Old 07-14-2013, 06:18 PM
  #8  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default light

I will, but when the car first starts no battery light appears,it within a minute it shows up, still a fuse issue ???
bixblk is offline  
Old 07-15-2013, 06:43 AM
  #9  
roadkill2
Senior Member
RACING JUNKIE
 
Join Date: Jan 2012
Posts: 628
Default

First, an Alternator WILL charge a battery. That's because the alternator is a dumb electricity generator. It just maintains a constant level of power to the battery and across the spectrum of your car's voltage/amperage requirements.

But it also has a lot to do with the battery type. Some batteries charge with an alternator better than others.

The old Lead/Acid batteries are the slowest to come back up, and if you just so slightly tip an older battery you've probably stirred up the crap in the bottom and shorted out a cell (or two). A battery of this type is usually considered "dead" at 10.5 volts.

With the "Gel Type" batteries, most are "deep cycle" and can be drained down to about 5 volts before they become difficult to recover, and with the little "Dry Cells", they're pure deep cycle and can be literally drained to nothing and yet recover in about 15 minutes.

It is a very good idea to start out with a fully charged battery (13.2 Volts)

The reason I state, emphatically, that an alternator is a battery charger is because that's what it does . . And it's the first thing it does after you start your car . . You pull about 2.5 volts , on average, when you start your car if it's a relatively new one with a computer, a HEI and a stereo. Those volts have to be replaced, and your alternator does that "on the Fly", while powering up your power seat, headlights, windshield wipers, etc . .

In the case of bixblk, it would sound like a "controls" (computer, ECM, etc) problem, but with todays systems, unless he can chase it down with an OBD box or get lucky and find the right dirty connection (Which is probably 50% of all electrical problems in the modern automobile) I certainly don't have even an educated guess . .
roadkill2 is offline  
Old 07-15-2013, 07:55 AM
  #10  
bixblk
Senior Member
DYNO OPERATOR
Thread Starter
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default light

I spoke to my buddy thats wrenches on ambulances and he said he has seen a bad diode kick on a battery light, but with a meter it appears to be charging, makes sense cause the didodes make the ac to dc ,but a regular meter may read it as a dc charging voltage. His tester/ machine is sophisicated enought to detect a non dc waveform, I dont like to bother him on mondays cause he is repairing the ambulances from the w/e. I gonna take the alt to a store to test it, it maybe a diode issue. Or a computer, but the alt is new.
bixblk is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service