750 Holley HO carb air gap intake ?

Old 09-17-2012, 06:25 PM
  #1  
cbtlr
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2007
Posts: 105
Default 750 Holley HO carb air gap intake ?

I was running a performer intake with a stock quadrajet..car was pretty consistent for brackets..I mounted a rpm air gap with a AED holley 750 dbl pump carb 73 primaries 80 seconds..Primaries has a 4.5 power valve the secondaries has no power valve...

Et's are better in the heat than cool air..I would think my et's across the board would be better in the night air but only gets worst as the night progress.Even after a 45 min cool off time in the night air still a loss in performance.

I am trying to set this car up for bracket racing.NO can do when my et's are all over the place..I am pretty consistent on my rt's time slip shows the car has taken a fall in performance in the cool air.Could I be a over jetted? Heat or cool night air car doesnt pull as it should on the upshift..

With the performer intake stock quad upshift in the 8th was I would say 2 seconds before the stripe..Yea some tall gears.Now with the air gap and holley I am in second gear a good 4 1/2 to 5 seconds before the stripe..Performance has improved but stumped on the loss of power in the cool air..

Any help well appreciated thanks..
cbtlr is offline  
Old 09-17-2012, 07:08 PM
  #2  
TS1955
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2007
Location: Lost Creek, WV
Posts: 533
Default

There are a few things you need to look at. I would check your float level, then check fuel pressure. Then take a look at your spark plugs. It sounds like you are a little on the lean side.

TS1955
TS1955 is offline  
Old 09-18-2012, 08:56 AM
  #3  
cbtlr
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2007
Posts: 105
Default

Float level is in the mid of sight plugs front and rear..The carb was purchased with 83 secondary jets..Ran it a few times and checked plugs with the 83's..Plugs were fouled out bad.I did replace plugs with NGK's and re jetted the secondaries with 80's..I will take a look at the new plugs to see if still running to rich or possibly lean.The engines seemed to perform better with the 80's..Fuel pressure is on a stock mechanical pump rated at 6.5..

Sbc edlebrock performer heads,full rollers 1.5's,RV cam,RPM air gap,AED 750 dbl pumper,hooker long tubes,flow masters...<<<< Some of the pieces to my puzzle.. Engine has under 8000 miles on it fairly fresh.Thanks for your reply..
cbtlr is offline  
Old 10-29-2012, 08:09 PM
  #4  
strat99
Junior Member
SHOW GUEST
 
Join Date: Feb 2005
Posts: 1
Default

Fuel level should barely trickle out of the plug holes with the plug out, sounds like they are too high. Doesn't explain your problem though, which is strange. Plugs don't explain it, nor does fuel pressure as it should be the same day or night. I run a 750 on my Air Gap but I run thru a cool can so fuel is always the same temp an no problems. Your issue sounds like it may be humidity related. Tune your carb with a vac gauge attached to the manifold. Adjust the mix screws until you obtain the highest vac rating at idle. Beyond that I have no other ideas to offer for this weird issue. Most engines run better in cooler air.
strat99 is offline  
Old 10-29-2012, 09:58 PM
  #5  
cbtlr
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Apr 2007
Posts: 105
Default

I believe I figured this out with the aid of another member who use to visit RJ..I run a 1 inch spacer with a vac line for my pcv..I am going to install a header evac system soon..

I plugged the vac line to the spacer and pulled my pcv valve for time trials last week..First pass beat my personal best et ever..I waited for some cool night air..Beat that personal best as well..

Car 60'd better and all across the board and gained 1 1/2 mphrs..I believe that hot crankcase vapor being pulled in through the spacer vacum port was defeating the purpose of the air gap ect..I did not touch a thing from my last visit to the track other than the pcv and spacer vac port.

Thanks
cbtlr is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service