trans brake reverse engagement

Old 01-06-2012, 04:01 PM
  #1  
masbliss
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jul 2006
Posts: 2
Default trans brake reverse engagement

I've been chasing this for a while. I have a Mega 450 through an MSD 3 Step that seems to engage the trans brake completely backwards. The trans brake engages when the button is released. If I put in a long delay, the delay occurs when I "push" the button in. Brake is always engaged when button is NOT pushed. I have checked and re-checked the wiring against diagrams. Any easy answers out there that I am missing? I figure someone has had this occur to them at some point.
masbliss is offline  
Old 01-06-2012, 04:26 PM
  #2  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Could this be a reverse action switch ?
Maybe change to a proper action switch.
TheYellaBrick is offline  
Old 01-06-2012, 04:38 PM
  #3  
masbliss
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jul 2006
Posts: 2
Default

I have used two differenct buttons--a Biondo and TCI (which are both trans brake buttons on my steering wheel). Both are momentary switches that engage when pressed which should close the circuit to both the Push Button circuit in the Mega 450 and and a +12V power source. Not convinced it is an improper switch...but I've been wrong before.
masbliss is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service