tranny leak

Old 10-08-2011, 03:04 PM
  #1  
rhino058
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Feb 2009
Posts: 19
Default tranny leak

My th350 is leaking tranny fluid from a hole infront of the lines for the tranny cooler. the holeis on the passenger side and is untapped and ive haad the tranny running before i just put a trans pak from b&m in it. i'm thinking of plugging the hole but not sure if its anything important. wondering if anyone has any ideas
rhino058 is offline  
Old 10-09-2011, 08:29 PM
  #2  
rob41willys
Senior Member
SENIOR BUILDER
 
Join Date: Nov 2007
Location: Tukwila, WA
Posts: 115
Default

Are you talking about the hole for the vent?
rob41willys is offline  
Old 10-10-2011, 03:44 AM
  #3  
rhino058
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Feb 2009
Posts: 19
Default

It could be i was going to just go ahead and plug and see what happens i started the motors to try to draw some of the fluid threw the tranny to see if i can add fluid now going to try later today hopefully works
rhino058 is offline  
Old 10-11-2011, 08:23 AM
  #4  
rob41willys
Senior Member
SENIOR BUILDER
 
Join Date: Nov 2007
Location: Tukwila, WA
Posts: 115
Default

If it is the vent DO NOT PLUG
rob41willys is offline  
Old 10-11-2011, 12:25 PM
  #5  
fast75vega
Senior Member
RACING JUNKIE
 
Join Date: Nov 2008
Location: Niagara Falls, NY
Posts: 965
Default

the only vent i recall on the th350 was up on top behind the bell about half way back :wink: you sure its not the oring on the dip stick tube or the tranny kick down cable? does it leak when it sits or just when its running?
fast75vega is offline  
Old 10-11-2011, 02:41 PM
  #6  
rob41willys
Senior Member
SENIOR BUILDER
 
Join Date: Nov 2007
Location: Tukwila, WA
Posts: 115
Default

You are correct I was thinking powerglide. The vent for a 350 is on the drivers side at the base of the bell housing. Is there a kick down cable on this transmission, that would be located just below the fittings for the cooler lines?
rob41willys is offline  
Old 10-11-2011, 04:54 PM
  #7  
rhino058
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Feb 2009
Posts: 19
Default

yea it only leaks when i was just plain adding fluid i started it for 30 seconds to suck fluid threw the internals so im going to try again to fill it tomorow
rhino058 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service