carb?

Old 09-18-2011, 07:06 AM
  #1  
lookingaround
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default carb?

i had a hp 1050 dominator on my motor...never had any problems what so ever with it..i let my truck set for a few months and when i cranked it up and drove it everytime i got into the 4 barrels it would pop and crack...i bought a new 950 proform double pumper for it put it on and it does the same thing...so i put a old 850 double pumper i had on it and now it doesnt pop but rolls the black smoke out..i jetted it down to 72 in front and 73 in back put a power valve plug in the rear and it still black smokes from to much gas...why all of a sudden are these carbs acting stupid? any help trying to get them straightened out would be greatly appreciated...my dad use to tune all my carbs and fix them but he passed away back in may and now im clueless...thanks for any help..
lookingaround is offline  
Old 09-18-2011, 08:20 AM
  #2  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default


BAD GAS ?

:shock: :shock: :shock: :shock: :shock:
TheYellaBrick is offline  
Old 09-18-2011, 05:00 PM
  #3  
lookingaround
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default

Originally Posted by DrivingMissDD

BAD GAS ?

:shock: :shock: :shock: :shock: :shock:
i did earlier but not now...lol...i think i found my problem...ill know tomorrow when i go back to the garage..ill keep you posted and thanks for the help
lookingaround is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service