BOOM!!

Old 05-26-2011, 05:11 AM
  #1  
MEMRACING62
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default BOOM!!

http://www.youtube.com/watch?v=d_8Fc9qAZcw
MEMRACING62 is offline  
Old 05-26-2011, 05:29 AM
  #2  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 3,996
Default

wow!!!!!!!!!!!!! :shock:
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 05-26-2011, 08:03 AM
  #3  
BEAST477
Senior Member
RACING JUNKIE
 
BEAST477's Avatar
 
Join Date: Feb 2007
Location: Michigan
Posts: 1,908
Default

Ouch :!: That will probably leave a mark.
BEAST477 is offline  
Old 05-26-2011, 08:20 AM
  #4  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default


OUCH !
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$ $$$$$$$$$$$
It started bogging down just before it blew. You'd athunk they'd of shut 'er down right then !?!?
:roll: :roll:
TheYellaBrick is offline  
Old 05-26-2011, 12:54 PM
  #5  
oldandtired
Senior Member
RACING JUNKIE
 
oldandtired's Avatar
 
Join Date: Dec 2008
Location: Sugar Hill, GA
Posts: 1,370
Default

I think we need a new gasket kit. :shock:
oldandtired is offline  
Old 05-26-2011, 03:22 PM
  #6  
bixblk
Senior Member
DYNO OPERATOR
 
bixblk's Avatar
 
Join Date: Dec 2004
Location: Chicagoland area
Posts: 472
Default $$$$$$$$$$

costly but better on the dyno than in the car when it scattered, as many people know when they come apart and your at the wheel you will remember that very well. Fluids are nasty on tires at high MPH
Now it is a sad tale, at the wheel it maybe more. The type of stuff we do causes things to break ? I still feel sorry $$$$$. Good luck guys and have a safe memorial w/e
bixblk is offline  
Old 05-26-2011, 05:52 PM
  #7  
TheRabbit
Senior Member
RACING JUNKIE
 
TheRabbit's Avatar
 
Join Date: Jan 2007
Location: Augusta, Ga.
Posts: 2,295
Default

Looks like they did that on purpose. No way in he!! would I run my motor that long at that high rpm. Make a few quick pulls to XXX RPM and be done.
TheRabbit is offline  
Old 05-26-2011, 07:02 PM
  #8  
laxking012
Member
JUNIOR BUILDER
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default

Did anyone else notice the exhaust hose seem to swell up a couple seconds before it blew?
laxking012 is offline  
Old 05-26-2011, 09:02 PM
  #9  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Strange. Either it got melting HOT or was 'blocked'...???
TheYellaBrick is offline  
Old 05-27-2011, 11:15 AM
  #10  
lively
Senior Member
RACING JUNKIE
 
lively's Avatar
 
Join Date: Nov 2004
Location: ILLINOIS
Posts: 2,191
Default

and then there are STUPID dyno operaters !!!!!!
you could see it failing in the exhaust----SHUT IT DOWN--A CASE OF MORE MONEY THEN BRAINS :shock: :evil:
lively is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service