th 350 tranny?/ engine seems to bog down?

Old 02-23-2011, 01:34 PM
  #1  
burnskustomz
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Mar 2009
Location: Booneville,Ms
Posts: 505
Default th 350 tranny?/ engine seems to bog down?

I just put a th350 tranny in my truck and when its in reverse it does good but when you put it in drive the motor seems to lose all power and it won't hardly go down the road. Anybody know what I seem to have done wrong?
burnskustomz is offline  
Old 02-23-2011, 03:14 PM
  #2  
fast75vega
Senior Member
RACING JUNKIE
 
Join Date: Nov 2008
Location: Niagara Falls, NY
Posts: 965
Default

sounds kinda like the converter is locked up. did you try and shift it manually....... does it still do it?
fast75vega is offline  
Old 02-23-2011, 07:10 PM
  #3  
burnskustomz
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Mar 2009
Location: Booneville,Ms
Posts: 505
Default

I did the day I first got it in and it helped a little but engine power still didn't fill the same you could tell something was wrong. But one day we were trying to drive it from the shop to the house and it went fine still going slow but when I came to a hill I could floor it and still no power and we ended up having to pull it to the house. Someone told me to take it out and replace the converter and someone else said I should check the govenor but thought I'd see what people on here thought.
burnskustomz is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service