Oil leak just started, don't know how

Old 02-21-2011, 09:26 AM
  #1  
laxking012
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default Oil leak just started, don't know how

I got a 1989 chevy 2500, we had a japser 350 engine put in it in 2005 about. the oil pressure has always been off the gauge since then so 60+. I was out just driving around town so it was a lot of go somewhere turn it off go in the store and then go somewhere else, for about a 2 hours. When i got home I was about to turn it off and i notice the oil pressure was somewhere about 45ish, which it's never been that low. So i looked under to see if it was leaking and there was drops coming off the oil filter. Could all that starting and stopping have caused the leak? i never really raced the engine in that time except for once when turning on the highway and trying to not get smashed by the car coming up behind me. Also where could the leak be coming from?
laxking012 is offline  
Old 02-21-2011, 10:28 AM
  #2  
itsabird
Senior Member
RACING JUNKIE
 
Join Date: Dec 2007
Location: ohio
Posts: 812
Default

What kind of oil filter is it?
itsabird is offline  
Old 02-21-2011, 10:32 AM
  #3  
laxking012
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default

Well it's not my truck, it's my dads. He's just letting me use it until i get another one. All i know is that the filter is big, blue and screws into the bottom back of the engine
laxking012 is offline  
Old 02-21-2011, 11:18 AM
  #4  
bbchevy
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Fountain,MICHIGAN
Posts: 856
Default Leak?

Oil COOLER Lines!
Very Notorious............?
Later
G 8)
bbchevy is offline  
Old 02-21-2011, 11:23 AM
  #5  
fast75vega
Senior Member
RACING JUNKIE
 
Join Date: Nov 2008
Location: Niagara Falls, NY
Posts: 965
Default Re: Leak?

Originally Posted by bbchevy
Oil COOLER Lines!
Very Notorious............?
Later
G 8)
X2...... i took the whole oil cooler assembly right off and bolted the old style one off an older 350 block.
fast75vega is offline  
Old 02-21-2011, 11:43 AM
  #6  
laxking012
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default

it looks like it's coming from a kinda cone shaped looking thing, looks like a valve. its just above the oil filter and behind the exhaust manifold on the drivers side. it hard to describe but if you know what i mean, what is it? is it part of the oil cooling?

here's a pic to help, it's circled

[img][/img]
laxking012 is offline  
Old 02-21-2011, 01:43 PM
  #7  
laxking012
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default

Also the truck for the past few years gets about 3000 miles a year. In the middle of Jan. I started using it as my daily driver. Could just using it a lot more have caused it to leak?
laxking012 is offline  
Old 02-21-2011, 02:10 PM
  #8  
fast75vega
Senior Member
RACING JUNKIE
 
Join Date: Nov 2008
Location: Niagara Falls, NY
Posts: 965
Default

looks like an oil sending unit or something...... never seen one like that?
fast75vega is offline  
Old 02-21-2011, 06:37 PM
  #9  
laxking012
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Oct 2009
Location: Delmar, MD
Posts: 83
Default

Now that you say that, an oil sending unit does make sense. There is a wire coming out the top, you can't see in the picture. Also with it leaking that would explain why the pressure dropped so much, right? I also noticed now the pressure is fine when i first start it, then once it's warm it drops lower than usual at idle.
laxking012 is offline  
Old 02-22-2011, 03:14 AM
  #10  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

Definately oil pressure sender. It has a shield on it. If you pull the shield off it looks like a normal op sender. My guess is that it's been bad for a while causing high readings pegging the gauge. I've seen that a lot on those trucks. Don't be surprized if the gauge reads lower after replacement.....

Johnny
johnracer is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service