REAR CAM BEARING

Old 12-01-2010, 05:50 AM
  #1  
JEFF69Z28
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2008
Posts: 496
Default REAR CAM BEARING

COULD IT HAVE A ROLLER TYPE BEARING WITH NEEDLE BEARINGS IN IT?I TOOK MY MOTOR OUT CHECKED ALL ROLLER ROCKERS AND LIFTERS THEY ARE ALRIGHT.BEHIND THE CAM GEAR THERE IS A ROLLER TYPE SPACER AND IT LOOKS TO BE OK ALSO.ANYONE HAVE A SUGGESTION WHERE THESE LITTLE NEDDLE BEARINGS CAME FROM OR MAYBE THEY ARE NOT NEEDLE BEARINGS,DOES THE OIL PUMP HAVE BEARINGS?REASON MOTOR IS OUT THE PICKUP FELL OFF THE OIL PUMP.SOLID ROLLER CAM,ROLLER LIFTERS AND ROCKER ARMS.DOUBLE ROLLER TIMING CHAIN,MILODIN HV OIL PUMP
JEFF69Z28 is offline  
Old 12-01-2010, 01:19 PM
  #2  
fla1976
Senior Member
RACING JUNKIE
 
fla1976's Avatar
 
Join Date: Aug 2007
Posts: 1,534
Default

Maybe you were sabotaged! :shock:
fla1976 is offline  
Old 12-01-2010, 02:04 PM
  #3  
pistonpopper
Junior Member
SHOW GUEST
 
Join Date: Nov 2008
Posts: 9
Default

would you possibly have a roller type cam button? may be damaged? also have seen the tips of roller timing gears break off and get into the lifter gallery and oil pan, and appear to look like rollers, but have a sharper edges if you look close... good luck
pistonpopper is offline  
Old 12-02-2010, 06:03 PM
  #4  
fla1976
Senior Member
RACING JUNKIE
 
fla1976's Avatar
 
Join Date: Aug 2007
Posts: 1,534
Default

Is this an engine that might have come apart before? The parts you found could have been wedged somewhere and finally worked their way into the pan. Might have no "bearing" on the present problem. ops:
fla1976 is offline  
Old 12-03-2010, 02:52 AM
  #5  
JEFF69Z28
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2008
Posts: 496
Default

Originally Posted by fla1976
Is this an engine that might have come apart before? The parts you found could have been wedged somewhere and finally worked their way into the pan. Might have no "bearing" on the present problem. ops:
Thats now what im thinking i took the thrust plate out from behind the cam gear pulled it apart and the needle bearings in it matched what i found in the oil pan but there was none missing in the thrust plate.Im thinking maybe the builder broke one and didnt think nothing went into the pan.
JEFF69Z28 is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service