Glide Neutral Grabbing

Old 11-29-2010, 04:24 AM
  #1  
chevyfireball
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Dec 2005
Location: Napier, New Zealand
Posts: 230
Default Glide Neutral Grabbing

Had the car on the stands warming up. Ran through the gears all good. Put the glide in nuetral and the rear wheels were still trying to turn. Couldn't be stopped with your foot. If I put on the foot brake the engine loaded a bit.

All cable settings etc were okay. The lever on the side of the glide clicked into place perfectly.

Put the car on the ground and it didn't seem to be pulling in nuetral so I took it out for the first qualifier. Launched hard out and 700hp of nitrous was flowing. The revs hit 7800rpm, the shift light came on and.... it didn't bloody shift. (Has a rpm activated solenoid shifter behind the hirst stick). Before ya know it the engines hitting the rev limiter and banging flames out the pipes. I took my foot off and thats about when smoke started pouring out the breather on the trans catch can. You coulda fried eggs on that glide and the smell of the fried oil would put a Chinese chip shop to shame.

Theres a lot of glitter in the trans oil and I've sent it to the tranny hospital. Thing is, it was a fresh trans, no runs. What do y'all reckon?
chevyfireball is offline  
Old 11-29-2010, 04:42 AM
  #2  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

BROKE! :cry:
MEMRACING62 is offline  
Old 11-29-2010, 07:43 AM
  #3  
markdunlap
Senior Member
DYNO OPERATOR
 
Join Date: Jan 2004
Location: central Illinois
Posts: 459
Default Glide

It is normal for any glide or other automatic trans to start rotating when in the air in neutral.
markdunlap is offline  
Old 11-29-2010, 07:55 AM
  #4  
mytmouz
Senior Member
RACING JUNKIE
 
mytmouz's Avatar
 
Join Date: May 2006
Location: Pelahatchie, MS
Posts: 995
Default

High gear clutches took a dump...
mytmouz is offline  
Old 11-29-2010, 06:08 PM
  #5  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

Can you tell us anything about the tranny? Did it still work in first after this happened? Whos valvebody and what high gear drum does it have?
kwkracing is offline  
Old 11-29-2010, 06:13 PM
  #6  
chevyfireball
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Dec 2005
Location: Napier, New Zealand
Posts: 230
Default

Glides in pieces. Clutch packs are okay. It has totaly destroyed a band. May be the band wasn't quite lined up with the drum correctly?
chevyfireball is offline  
Old 11-29-2010, 10:23 PM
  #7  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

It would be hard for the band to not line up. Does the piston have a good sealing ring? When you say the band was tore up, do you mean it was smoked?
kwkracing is offline  
Old 11-30-2010, 03:33 PM
  #8  
wrightway
Senior Member
SENIOR BUILDER
 
Join Date: Feb 2005
Location: LAWTON MI
Posts: 113
Default Re: Glide

Originally Posted by markdunlap
It is normal for any glide or other automatic trans to start rotating when in the air in neutral.
X2
wrightway is offline  
Old 11-30-2010, 03:43 PM
  #9  
wrightway
Senior Member
SENIOR BUILDER
 
Join Date: Feb 2005
Location: LAWTON MI
Posts: 113
Default

Originally Posted by chevyfireball
Glides in pieces. Clutch packs are okay. It has totaly destroyed a band. May be the band wasn't quite lined up with the drum correctly?
The band is applied in low gear and released for high
Not sure how you could destroy the band
wrightway is offline  
Old 11-30-2010, 03:49 PM
  #10  
wrightway
Senior Member
SENIOR BUILDER
 
Join Date: Feb 2005
Location: LAWTON MI
Posts: 113
Default

Originally Posted by mytmouz
High gear clutches took a dump...
Is the clearance correct?
wrightway is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service