Darts left when I lift

Old 11-22-2010, 09:09 AM
  #1  
jglennfillmore
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: May 2010
Posts: 1
Default Darts left when I lift

The car has some pull to the right under acceleration and then darts left when I lift. The car is a 2500 super gas strut front end and four link rear. The front end was just lined up so I'm thinking maybe something in rear. Nothing appears to be broken or bent. This is a new car to me.
jglennfillmore is offline  
Old 11-22-2010, 10:16 AM
  #2  
ajk
Senior Member
DYNO OPERATOR
 
Join Date: Jun 2009
Location: Wi
Posts: 522
Default

Look for posts by jreiley he had a similar problem not to long ago. maybe some of the responces he got may help you. AL...
ajk is offline  
Old 11-22-2010, 07:54 PM
  #3  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Have you checked the chassis square ?
Is the rear end square with the chassis/front axle line ?
Sounds like it could be the right side wheelbase is a tad longer than the left.
TheYellaBrick is offline  
Old 12-07-2010, 06:12 PM
  #4  
coolracing
Senior Member
MASTER BUILDER
 
Join Date: Jan 2008
Location: Yooper
Posts: 168
Default

Does the car have a anti roll bar?
coolracing is offline  
Old 12-08-2010, 02:32 PM
  #5  
TheRabbit
Senior Member
RACING JUNKIE
 
TheRabbit's Avatar
 
Join Date: Jan 2007
Location: Augusta, Ga.
Posts: 2,295
Default Re: Darts left when I lift

Originally Posted by jglennfillmore
The car has some pull to the right under acceleration and then darts left when I lift. The car is a 2500 super gas strut front end and four link rear. The front end was just lined up so I'm thinking maybe something in rear. Nothing appears to be broken or bent. This is a new car to me.
Lets start from scratch. You said the car was new to you. Did someone have it before you or did you build it? If someone else had it did it drive straight? What have you done to it since you've had it?
May sound crazy, but if something changes always think back to where the problem started.
TheRabbit is offline  
Old 12-08-2010, 03:16 PM
  #6  
gearhead1011
Senior Member
EXPERT BUILDER
 
gearhead1011's Avatar
 
Join Date: Jan 2004
Location: Shepherdsville, KY
Posts: 313
Default

Check the bump steer.
gearhead1011 is offline  
Old 12-08-2010, 06:36 PM
  #7  
coolracing
Senior Member
MASTER BUILDER
 
Join Date: Jan 2008
Location: Yooper
Posts: 168
Default

Originally Posted by gearhead1011
Check the bump steer.
X2 J.A.
coolracing is offline  
Old 12-08-2010, 06:46 PM
  #8  
TS1955
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2007
Location: Lost Creek, WV
Posts: 533
Default

Put the car on a set of scales. Check and see how much pre-load is in the chassis.

TS1955
TS1955 is offline  
Old 12-08-2010, 07:49 PM
  #9  
jed5161
Member
CRAFTSMAN
 
Join Date: May 2008
Posts: 51
Default

had a super gas camaro doing simular thing....finally got to the point where it was swaying all the way down the track. Tore all the rear end suspension apart and found panhard tube bending under load and all heim ends were .002-.004 loose. replaced all ends and converted panhard rod into the newer style x-link setup and was fine after that.
jed5161 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service