C4 w/pa internals w/art carr servo&valvebody?Help please

Old 05-25-2010, 04:10 PM
  #1  
krose311
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jul 2007
Posts: 4
Default C4 w/pa internals w/art carr servo&valvebody?Help please

I have a built up c4 that has all PA internals and ART CARR servo and manual valvebody w/ transbrake. Well this is my problem. the guys I got car from said they put the A.C. valvebody in the trans and shifter great from 2/3 shift but when it was put in first the tires would lock up on it. Now there is a sylenoid looking thing that came with the valvebody and they said they didnt where to install it so they just didn't . They thought there might be a piece of garbage that got sucked up in it and that might be the problem. My question is does this sound like the valvebody does have a transbrake in it and they just didn't install the sylnd and thats why it didn't work for them??? or do you think there is something wrong with it all together??? One of the guys said they thought it did have a transbrake and the other guy said you could install a brake in it so I am lost. I'M SORRY IF THIS IS A VERY DUMB QUESTION BUT MYSELF HAVE NOT A CLUE WHEN IT COMES TO TRANSBRAKES OR TRANS. IN GENERAL BUT COULD SOMEONE HELPOUT i KNOW THERE ARE VERY SMART PEOPLE ON THIS SIGHT AND WOULD APPRECIATE SOME INSIGHT. There is a pic of sylenoid looking thing as well as a pic of the valvebody in ad#1900806. ops: Thank you for your time, Korey
krose311 is offline  
Old 05-25-2010, 04:40 PM
  #2  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

Well, I'm not that familar with C-4's, but on any other trans, the transbrake solenoid installs in place of the vacuum modulator. If it's a transbrake valvebody, and it has a vacuum modulator installed instead of the solenoid, it's probably pushing the valve and applying the transbrake. Most brakes only work in low, so the trans would work in 2nd and 3rd....I'd try installing the solenoid.

just a guess,
Johnny
johnracer is offline  
Old 05-25-2010, 08:15 PM
  #3  
krose311
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jul 2007
Posts: 4
Default

Thank you! I will def. try that, actually its on a lift now so in the morning its going to be tried and I will let you know if it works. Thanks again! There are pics of the sylenoid looking thing as well as the valvebody in ad# 1900806.
krose311 is offline  
Old 05-25-2010, 08:42 PM
  #4  
krose311
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jul 2007
Posts: 4
Default

[img][/img] I'm not sure how to post images but I was going to show what the valvebody looked like as well as the sylenoid too. [/url][img][/img]
krose311 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service