WHY I AM NOT A FORD FAN!!!!!!!!!!!!!!!!!!

Old 04-13-2010, 09:27 PM
  #1  
blownalky3
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Jun 2003
Posts: 241
Default WHY I AM NOT A FORD FAN!!!!!!!!!!!!!!!!!!

So we try to help my brother-in-law get a 98 Mustang convertible running for his daughter. It sat for 5 years. We can't start it and trace it to fuel pump. It ran awesome squirting fuel in the throttle body, so we knew it needs the pump. Pull the tank and find tons of rust. Order a new tank, new pump, new filter and lines. Get it running after new pump installed. Runs rough and then cleans up and runs pretty good. So after 50 miles he goes out and it wont start. If we put fuel in the throttle body it runs till it burns off and dies. We trailer it back to my house and while it gets fuel, the pressure seems weak. We replace the regulator...nothing. We replace the fuel module ($300+)......nothing. So we decide it has to be a bad fuel pump. Pull the Fu&%*ing tank again and replace the fuel pump. NOTHING STILL!!!!!!!!!!!! So he loads it up and brings it to a shop where they put it on a computer. It says it is in theft mode or being stolen???????? He asks the owner if he has another key. So he gets the other key and IT FIRES RIGHT UP!!!!!!!!!!!!!!!!!!!!!
SO FORDS CAN

HAVE THE KEY TURN THE CAR OVER
ROLL DOWN THE WINDOWS AND WORK ACCESSORIES
BUT NOT FUC&ING START THE THING UP!!!!!!!!! UNBELIEVABLE
blownalky3 is offline  
Old 04-14-2010, 10:12 AM
  #2  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,011
Default

Paul,
I hear ya!! you need a scanner for everything these days. at our shop I dont call our guys "techs", I call them parts replacers since the scanner tells them whats broke!
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 04-14-2010, 10:49 AM
  #3  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

Believe it or not, GM has antitheft systems that will do the same thing when they mess up......so it's not just a Ford thing.
Oh and Chris, I've been a tech/mechanic for 27 years and an ASE master tech for 20 of those, and I've NEVER had a scanner tell me what's broke.
They can steer you in the right direction or lead you astray, but it's up to a real "tech" know the difference and find what's broke......jmo
Johnny
johnracer is offline  
Old 04-14-2010, 02:00 PM
  #4  
Harbone
Moderator
RACING JUNKIE
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,011
Default

thats a running joke at the dealership johnny, I have been in the parts business 28 years and also ASE certified parts specialist the last 12 (they only started it 12 years ago). we always say our techs we all be replaced by machines someday! VW are the worse, without a scanner you cant diagnose crap, even the radios!
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 04-14-2010, 03:04 PM
  #5  
blownalky3
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Jun 2003
Posts: 241
Default

My GM wont even turn over if the anti-theft is triggered. The Ford does everything just wont run.
blownalky3 is offline  
Old 04-14-2010, 05:15 PM
  #6  
bigray
Senior Member
DYNO OPERATOR
 
Join Date: Jul 2003
Location: Chelsea Oklahoma
Posts: 558
Default

i would have put a BULLET right between the pony's eyes..LOL
bigray is offline  
Old 04-14-2010, 05:58 PM
  #7  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

Time to convert it to a carb ........Personally, I just do NOT have the required patience anymore to trouble shoot and work on this 'new' stuff....
TheYellaBrick is offline  
Old 04-14-2010, 06:19 PM
  #8  
signsbyesa
Senior Member
RACING JUNKIE
 
Join Date: Feb 2004
Location: san antonio, texas
Posts: 1,233
Default

hey i can chew gum and drive a ford :wink:
signsbyesa is offline  
Old 04-14-2010, 06:24 PM
  #9  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

carb?? when was the last car built with a carb ? 87? 88?
MEMRACING62 is offline  
Old 04-14-2010, 06:38 PM
  #10  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

It woulda been one of them thar eelectronic carbs I thunk on a domestic as the japs were into FI in '79-'80.....or thereabouts.
TheYellaBrick is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service