unclogging oil passage from filter to sending unit on sbc

Old 02-21-2010, 08:08 AM
  #1  
Salter1982
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Jan 2010
Posts: 2
Default unclogging oil passage from filter to sending unit on sbc

The oil passage from the filter to the top of the motor is clogged pretty tight. Took adapter off and the wooly type seal was gone and i think it got pushed in the passage. need suggestions on how to get it out.

thanks
Salter1982 is offline  
Old 02-21-2010, 09:24 AM
  #2  
dragonmaster093
Senior Member
RACING JUNKIE
 
Join Date: Mar 2009
Location: kingsport tn
Posts: 1,735
Default

please do not make 2 threads on same topic when some one has a viable option they will post thanks
dragonmaster093 is offline  
Old 02-21-2010, 09:59 AM
  #3  
mopar1968
Senior Member
RACING JUNKIE
 
mopar1968's Avatar
 
Join Date: Dec 2006
Location: Abingdon,Virginia
Posts: 3,579
Default

Try compressed air first, shoot down from sending unit first :!: :!:



''JUST MY TWO CENT'S WORTH''
mopar1968 is offline  
Old 02-23-2010, 02:52 AM
  #4  
kbartley
Senior Member
EXPERT BUILDER
 
Join Date: Oct 2007
Location: Staunton,VA.
Posts: 251
Default

plug it off and move to the side of the block just above the filter take out the plug and put youre sending unit (gauge line there)there.
kbartley is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service