Camshaft selection/ choice

Old 12-28-2009, 07:57 PM
  #1  
Birddog95
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 49
Default Camshaft selection/ choice

Little help from the forum techs needed.
I am running a 598 BBC in our 240" Racetech 4 link dragster. This year our best et was a 7.71 (averaged 7.82) @ 172 MPH (averaged 169/170). A little info on the motor, we are using a edelbrock Victor intake, Pro topline 360 heads, 14:1 CR, and fueled by a George Rupert 1150 alky carb and 4.10 gears with 33.5 hoosiers. I found that others seem to be out mile/hr me at the same et (1-2 MPH+). Now when I bought the car last year, the fellow told me that there is a small cam in the car. I tryed e-mailing CompCams with my info but 3 weeks later still nothing. I've heard that great gains can be made by going to a 7/4 swap cam. Any thoughts on this and our suggestions on cams?- Lance
Birddog95 is offline  
Old 12-29-2009, 06:43 AM
  #2  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default Re: Camshaft selection/ choice

Originally Posted by Birddog95
Little help from the forum techs needed.
I am running a 598 BBC in our 240" Racetech 4 link dragster. This year our best et was a 7.71 (averaged 7.82) @ 172 MPH (averaged 169/170). A little info on the motor, we are using a edelbrock Victor intake, Pro topline 360 heads, 14:1 CR, and fueled by a George Rupert 1150 alky carb and 4.10 gears with 33.5 hoosiers. I found that others seem to be out mile/hr me at the same et (1-2 MPH+). Now when I bought the car last year, the fellow told me that there is a small cam in the car. I tryed e-mailing CompCams with my info but 3 weeks later still nothing. I've heard that great gains can be made by going to a 7/4 swap cam. Any thoughts on this and our suggestions on cams?- Lance

Best all around cam for your combo is a Erson 420-116 we call it the "asshole" grind as it works well in anything from 496 to 632 .
http://www.rehermorrison.com/PdfFile...ationChart.pdf
You can view specs there 806/765 284/[email protected] on a 112, I install mine @ 110 though.
There is very little hp in a 4/7 swap if any at all.

Now onto your combo and possibly why it is slow mph wise, them heads are not the ticket for that motor and are likely not helping it up high.
What converter specs and rpms after shift ? Converter is huge for mph/et on your combo, I've got several converters and I can change my mph by 5 with just a converter swap. Hope this helps
hammertime is offline  
Old 12-29-2009, 09:08 AM
  #3  
shawnp
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Ohio
Posts: 937
Default

235 Race Tech Swingarm. 582 with the Brodix 3xtra oval heads. Compression is very close. We ran the RM 420-117 cam. Car ran 7.60's at 174mph. Like David said, the heads are not helping you any with your combo.
shawnp is offline  
Old 12-29-2009, 12:17 PM
  #4  
Birddog95
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 49
Default

Thanks David and Shawn. I'm running a ATI 9" converter flash stall is 6200/ brake is 6050. I can't quite remember what the RPM drops to but I believe its about 6400, shifting at 7200 and crossing the line is 7550. I tried shifting at 7400 but its border line of no change and slowing down.
I saw an interesting articial on the Pro Topline 360 heads
http://speedtalk.com/forum/viewtopic...line+bbc+heads
and it seems to be a preference thing ????? If you get a chance to read the responces, I'd be curious to see your thoughts on what these other guys said.
Birddog95 is offline  
Old 12-29-2009, 03:03 PM
  #5  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

I've read that post in the past, I think someones dyno was happy with the #'s I read on there. I've seen these heads in person and also seen them on several combos they are a nice head for a street motor or a lower hp bracket stuff but wont never make hp like a brodix, dart or bmf head does IMO

Your converter sounds right, whats your current cam specs. Your MPH is not off for that et though its fairly normal.
hammertime is offline  
Old 12-29-2009, 05:05 PM
  #6  
shawnp
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Ohio
Posts: 937
Default

I can tell you we leave at 3800, shift at 7200 and hits the traps at 7100. When we stall checked the converter on the jackstands it was 6550-6600 I believe. The car is 60 footing 1.09-1.10 on average. The cam we used is not very aggressive down low but pulls like a freight train out top. The car has a 4.10 gear and the big hoosier 34.5 on it.

This motor was just a start. The new 582 is sitting on the floor waiting for the new Race Tech to get here. It will have a little more compression and has a different cam that should make it a little more aggressive down low. The cam we are using is a custom grind from Sunset. The goal with this motor is mid 7.50's so there is not a need to buy a new -15 suit for advanced ET.
shawnp is offline  
Old 12-29-2009, 05:09 PM
  #7  
Birddog95
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 49
Default

I'm not sure what cam is in the motor. All I know is the fellow I bought the car from said that it was a small cam so it would hammer the springs as bad (????). The motor just seems to nose over on the top end great to 1/8 mile (1.12- 60' 4.98- 660') but flattens out on the 2nd half. I figured it was the cam but maybe its the head/ intake combo?
Birddog95 is offline  
Old 12-29-2009, 06:14 PM
  #8  
shawnp
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Ohio
Posts: 937
Default

Lance,

I remember a guy asking about the same set up. It was a car that belonged to my buddy Evan Kirk. That car ran 7.50's here in Ohio during the summer. Is this the same car?

Your 60 and 660 numbers are slow. The car is picking up down track. It is making power but it does not appear you are getting it to the ground. Have you gone thru the trans or converter to make sure you have no issues there?
shawnp is offline  
Old 12-29-2009, 09:06 PM
  #9  
Birddog95
Member
MASTER JOURNEYMAN
Thread Starter
 
Join Date: Sep 2007
Posts: 49
Default

HEY!!! Right on Shawn. This is Evans old car. We love it. Just at our altitude (base 2300 corrected 4400') the car doesn't run the numbers he was. I can tell its a wicked 1/8 mile car. I remember one race w ran 6- 4.99* in a row (1/8th).
As for the tranny, yet we went right through it, but didn't touch the converter. I asked my tranny guy yesterday whether I should send it in to get checked over.
When we first got the car here we had the 4000 launch chip in and the car would come out of the hole and unloaad them 20' out (couple rotations) netting us 1.14- 1.16 60'. We slowly bumped up the launch and ended up at 5400 to get 1.12- 1.13 60'. I'm not that much of an expert when it comes to 4 links and it ran consistant so we left it pretty much alone.
I'm also contimplating stepping up the tire from 33.5 to a 34.5. Hoping this will help the car pull a bit more.
Birddog95 is offline  
Old 12-30-2009, 05:00 AM
  #10  
shawnp
Senior Member
RACING JUNKIE
 
Join Date: Mar 2003
Location: Ohio
Posts: 937
Default

The tire change could be the wrong direction. I would tell you to call down to Russ at Race Tech and chat with him or Jeff and see what they recommend for your situation on the 4-link bars. A lot of years experience down there with them boys and they can get you where you need to be. If your conditions are just that bad, it sounds like you are making the most of what you can.
shawnp is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service