Another Filter Question

Old 11-06-2009, 06:33 PM
  #1  
newjack42
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Jun 2009
Location: New Richmond, WI.
Posts: 87
Default Another Filter Question

Here a couple months ago i lost my lil 3.8L ford in my mustang. After lookin around i seen that the oil filter o ring blew out ran her out of oil in a heart beat and so on. I had a WIX on there. Later that day i bought some cheap oil and a filter and fired it back up. Made some nasty noises haha but it didnt take 5 seconds befor i had a puddle of oil on the ground. Pulled the filter off same thing blew the o ring out.What could have happened to cause it to be pushin out the oil filter o rings?
newjack42 is offline  
Old 11-06-2009, 06:50 PM
  #2  
DirkaDirka
Senior Member
RACING JUNKIE
 
DirkaDirka's Avatar
 
Join Date: Jul 2009
Location: Clarksville, TN
Posts: 1,954
Default

Too much oil pressure maybe??
DirkaDirka is offline  
Old 11-06-2009, 07:08 PM
  #3  
mopar1968
Senior Member
RACING JUNKIE
 
mopar1968's Avatar
 
Join Date: Dec 2006
Location: Abingdon,Virginia
Posts: 3,579
Default

Bypass valve stuck open in oil pump, sludge build up :!: :!:



''JUST MY TWO CENT'S WORTH''
mopar1968 is offline  
Old 11-06-2009, 07:12 PM
  #4  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default


X2
TheYellaBrick is offline  
Old 11-07-2009, 05:25 AM
  #5  
outlaw256
Senior Member
RACING JUNKIE
 
Join Date: Mar 2008
Location: falkville al
Posts: 1,766
Default

sidin with mpoar on this one. also im sure you know how to put a filter on but ive seen it bunches of times and by guys who know what their doing. tightening then too tight?
outlaw256 is offline  
Old 11-07-2009, 05:40 AM
  #6  
suicidebomb
Senior Member
RACING JUNKIE
 
Join Date: Jul 2007
Location: Independence, Missouri
Posts: 1,188
Default

<----This one pegs the gauge(100+psi) at wot. It doesn't leak or blow past the o-ring. I don't think it's pressure alone. If you're getting the filter on too tight, it will tho'. My Filter bypass is blocked, so all oil goes thru the filter.
suicidebomb is offline  
Old 11-07-2009, 07:09 AM
  #7  
bjuice
Administrator
RACING JUNKIE
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

the By pass is 1st thought..i see your from WI...very cold up there now...what weight oil do you use ?..i think your following what i am saying here
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 11-07-2009, 07:56 AM
  #8  
curtisreed
Senior Member
RACING JUNKIE
 
curtisreed's Avatar
 
Join Date: Feb 2004
Location: KIEFER, OK.
Posts: 1,311
Default

I would think if the bypass were stuck open it would not build pressure that high. Maybe stuck closed?

Curtis
curtisreed is offline  
Old 11-07-2009, 03:50 PM
  #9  
fla1976
Senior Member
RACING JUNKIE
 
fla1976's Avatar
 
Join Date: Aug 2007
Posts: 1,533
Default filter

Did you check to make sure the old "O" ring was completely removed?
fla1976 is offline  
Old 11-07-2009, 04:02 PM
  #10  
TS1955
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2007
Location: Lost Creek, WV
Posts: 533
Default

I agree with fla1976 on this...those O-rings are recessed in a groove in the filter. In order to "blow" one out it would have to be double stacked.
JMO!

TS1955
TS1955 is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service