99 s-10 blazer brake light?

Old 10-11-2009, 12:38 PM
  #1  
wrightway
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Feb 2005
Location: LAWTON MI
Posts: 113
Default 99 s-10 blazer brake light?

Not sure what to look for next need help
Rear left side brake light not working
Works when the right side turn signal is on but if the turn signal is turned off I lose the left brake light
Left turn also works fine
I have checked all the bulbs and wiring in the rear looks good
I have also removed all trailer wiring did not help
wrightway is offline  
Old 10-11-2009, 01:14 PM
  #2  
oldandtired
Senior Member
RACING JUNKIE
 
oldandtired's Avatar
 
Join Date: Dec 2008
Location: Sugar Hill, GA
Posts: 1,370
Default

I had an issue similar on a 66 Nova and it was a poor ground causing feedback thru the blinker circuits. Something else to check. Dave
oldandtired is offline  
Old 10-11-2009, 07:40 PM
  #3  
TheYellaBrick
Senior Member
RACING JUNKIE
 
TheYellaBrick's Avatar
 
Join Date: Mar 2008
Location: Emmett, Idaho
Posts: 7,334
Default

I've seen turn sig switches do some really weird stuff to the lighting system......You can chase the problem for DAYS and it'd be that lousy signal switch ! :x :x :x :x
TheYellaBrick is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service