holley 750 double pumper

Old 07-01-2009, 08:33 AM
  #1  
Harbone
Moderator
RACING JUNKIE
Thread Starter
 
Harbone's Avatar
 
Join Date: Aug 2007
Posts: 4,010
Default holley 750 double pumper

I had a great working (old) holley 750 dp on my car that had some fuel bowl srews stripped out so I decided to install a Proform center body. I put all new parts (needles, floats, gaskets, squirters, etc.) and cleaned everything else. I installed the carb and now I cannot get it to idle? It will run at about 1500 rpm and rev up fine but as soon as I start backing down the idle screw it dies like there no gas going thru the idle circuit. any suggestions?
__________________
Chris

As close to "Normal" as I can get...
Harbone is offline  
Old 07-01-2009, 10:14 AM
  #2  
CamBirdRacing
Senior Member
DYNO OPERATOR
 
Join Date: Feb 2009
Posts: 510
Default

Probably still has crap in the orfices fromthe machining process.
CamBirdRacing is offline  
Old 07-01-2009, 05:09 PM
  #3  
Scooterz
Senior Member
RACING JUNKIE
 
Join Date: Mar 2006
Location: EUGENE,OR.
Posts: 3,408
Default

Harb:

I have only had that symptom once when there was a piece of gasket material(very small) stuck inside the needle & seat assmbly. It had a high weak idle like you explained. Good luck Brutha!!! Scoot
Scooterz is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service