Rons 1060 Terminator

Old 06-28-2009, 07:48 PM
  #1  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default Rons 1060 Terminator

Need some jetting advise. Is anyone running a 1060 rons terminator on a 468. I currently have 33 jets in the nozzles and a 90 pill in the barrel valve. I'm still too rich. The motor has a slight bog and slow coming up on the converter. I changed the pill to 94 and it hits the converter alot faster. A couple of racers in my area are running the same setup with alot bigger motors and are running 38 to 39 jets in the nozzles and 70 to 75 pill in the barrel valve. I just need some sort of equal comparison.
onedragracer is offline  
Old 06-28-2009, 08:39 PM
  #2  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default Re: Rons 1060 Terminator

Originally Posted by onedragracer
Need some jetting advise. Is anyone running a 1060 rons terminator on a 468. I currently have 33 jets in the nozzles and a 90 pill in the barrel valve. I'm still too rich. The motor has a slight bog and slow coming up on the converter. I changed the pill to 94 and it hits the converter alot faster. A couple of racers in my area are running the same setup with alot bigger motors and are running 38 to 39 jets in the nozzles and 70 to 75 pill in the barrel valve. I just need some sort of equal comparison.

Whats the leak on the barrel valve? I'd think 33 and 90 would be lean.
hammertime is offline  
Old 06-28-2009, 08:43 PM
  #3  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

26% on the barrel valve, I've rechecked it several times. The butterflies are set at .008. The pump is a 0-0.5 and the complete setup came off a 565 that ran 7.54 in Dallas last year. I'm beginning to think this pump flows way too much for my motor. The pump gear is a 36 and the crank gear is 18.
onedragracer is offline  
Old 06-28-2009, 09:14 PM
  #4  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

0 1/2 pump should work fine, how good of a 468 we talking ?
do you have a egt if so whats idle egt ?

If you have a primer plus can you make it fat and see if it comes up faster on conv with just gas ?
hammertime is offline  
Old 06-28-2009, 10:36 PM
  #5  
zipper06
Senior Member
RACING JUNKIE
 
Join Date: Jan 2006
Location: La.
Posts: 2,890
Default

I too think the nozzles are too small, i run 32's with a 0-1/2 on a 377" bowl with .085/.095 depending on the weather, my friend runs #35 nozzles with a bowl and 421" with .070/.075. I'm thinking you need atleast 35's/37's with a 468" motor.
I run 22% leakdown with the blade set at .005, we don't run a hi-speed bypass.

JMO

Zip.
zipper06 is offline  
Old 06-29-2009, 05:01 AM
  #6  
dparker
Senior Member
RACING JUNKIE
 
Join Date: Jun 2003
Location: Hobbs, NM
Posts: 842
Default

David this is the car I called you about. He had 38 and 90s and wouldn't go but to 3800rpm on the converter unless he went up on wot real slow, then it would go to 5800. James Monroe said he thought 35s might help. He didn't have any 35s so he tried 33s. He also removed the check valve and no help. Air here at 6500 to 7000. With the 33s and 90s he said its still sluggish going up on converter, but better than the 38s. 468 probably should be around 700hp, give or take 50hp. I'm not for sure but isn't an 0-.5 for 750 hp and up and a 0 pump for 750 hp and down?
dparker is offline  
Old 06-29-2009, 06:32 AM
  #7  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

I thought it may be the same setup. I'd of bet a 100 bucks it was the check valve. Like I said above this thing should want 35/80-90 pill for sure. I used to run the 0 1/2 pump on a sb that might of made 650 and had no issue. Did you guys check and make sure the pulleys are right, meaning its not over driving the pump ?

No egt I assume ?
hammertime is offline  
Old 06-29-2009, 07:50 AM
  #8  
dparker
Senior Member
RACING JUNKIE
 
Join Date: Jun 2003
Location: Hobbs, NM
Posts: 842
Default

I was sure hoping taking out check ball would fix it also. He doesn't have an EGT yet. and has 18/36 on the pulleys. Sure is acting like to much pump though. James is going to put the return line in a 5 gal fuel can this evening to check the return, just to make sure there's not a problem there. Our air this time a year is 7000ft. Maybe James Monroe will answer his phone today. Just hoping you had another fix in you bag of tricks.
Hammer/Flex the cat.lol.
dparker is offline  
Old 06-29-2009, 08:13 AM
  #9  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

What color is the barrel valve gray ?

I wish I had a small pump i'd send it to ya just to rule it out. I also tried calling Monroe this AM ... ring ring ring and voicemail is all I get. :evil:
hammertime is offline  
Old 06-29-2009, 02:08 PM
  #10  
onedragracer
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Aug 2007
Location: Odessa Texas
Posts: 81
Default

David the barrel valve is purple. No high speed lean out yet, I have it just haven't installed it yet. I'm gonna put 36 jets in the nozzles tonight and jet the barrel valve from there and see what happens.
onedragracer is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service