HELP!! 99 tahoe timing

Old 04-01-2009, 09:13 AM
  #1  
deltadog74
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Feb 2009
Posts: 6
Default HELP!! 99 tahoe timing

HELP!!! i have a 99 tahoe with code po 340 (cam senor). here is my problem. i changed the cam sensor and it did not fix the problem. it is missing at highway speads. last night i pulled the dist. out with the cap and rotor all in one. i turned the gear on the distributor but not the crank. when i put it back in it is acting like it is out of time, backfiring, really erratic idle, cutting off. i loosened the hold down clamp and tried turniung the distributor like the old non computer kind and it tried to run a little better but would not stay cranked. did i screw up the timing by turning the gear and therefore moving the rotor and if i did is there and easier way to get it back on time than bringing the #1 to tdc and setting it like that? if there is i would like to know cause that is a pain in the ass as you know. anyone with advice please help, thanks
deltadog74 is offline  
Old 04-01-2009, 02:24 PM
  #2  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

ya sure did! first you have to get top dead center #1 on front of engine there is a timing pointer with one line , line that up with line on balancer, remove dist cap & leave rotor on. look at base of dist , there is two marks one says 6 the other says 8, if its a v8 line up eletrode on rotor with proper mark. put cap back on and start. if no code pops up you are ok, if it does, turn dist 2 deg one way ,if no code your ok, if code 2 deg opisite way. hope this helps
MEMRACING62 is offline  
Old 04-01-2009, 07:34 PM
  #3  
deltadog74
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Feb 2009
Posts: 6
Default

man thanks! i kinda figured that. is there anything i need to remove to be able to see the pointer or to be able to turn the crank? i tried to today and there is so much more crap in the way than it used to be. why did they move away from just being able to turn the distributor and set the timing and you're on your way!
deltadog74 is offline  
Old 04-01-2009, 08:09 PM
  #4  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

TAKE THE DIST CAP OFF AND LOOK ALONG THE EDGE OF THE DIST YOU WILL SEE THE NUMBERS STAMPED THERE. IN LAST POST I FORGOT TO SAY TOP DEAD CENTER COMPRESION STROKE. BAR ENGINE OVER WITH BOLT ON THE BALANCER.TO SEE THE POINTER ON FRONT OF ENGINE I USE A SMALL MIRROR AND TROUBLE LIGHT , i HAVE A BORESCOPE NOW THAT MAKES IT A LOT EASIER. this will not get rid of po 340 , this code falure of signal from cam sensor, this can be caused from bad ignition wires, bad coil etc creating magnetic interference in area, check all those . use scan tool to clear code (after dist is put back in properly).
MEMRACING62 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service