TH350 Whining Noise

Old 03-30-2009, 09:27 PM
  #1  
strokersnova
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Feb 2009
Posts: 3
Default TH350 Whining Noise

I have a TH350 in my 68 Camaro that I bought.

I noticed that the transmission makes a whining noise when you put in into gear, but I don't notice any problems with drivability or shifting. I checked the fluid and its full.

Is this normal for this type of transmission? I think the car was a bracket car at one time and this was the tranny they used so I'm wondering if this is normal.

I can buy a rebuilt TH350 for about $250 so I'm wondering if I should change it out because I'm looking to sell the car and I don't want anyone to have problems with it.
strokersnova is offline  
Old 03-30-2009, 09:29 PM
  #2  
Tod74
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Posts: 4,143
Default

sounds like the pump is going to go kaput. I aint no tranny guy though
Tod74 is offline  
Old 03-31-2009, 06:04 AM
  #3  
MEMRACING62
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: orland pk il
Posts: 2,429
Default

X2 , change fluid and filter see if that quiets it.
MEMRACING62 is offline  
Old 04-20-2009, 12:48 PM
  #4  
CamBirdRacing
Senior Member
DYNO OPERATOR
 
Join Date: Feb 2009
Posts: 510
Default

Sounds like my ex g/f's daughter.
CamBirdRacing is offline  
Old 04-20-2009, 02:40 PM
  #5  
Drtmod5
Senior Member
MASTER BUILDER
 
Join Date: Feb 2004
Location: IN
Posts: 177
Default

LMAO Cambird!! :mrgreen:
Drtmod5 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service