Regulator!!

Old 02-04-2009, 09:04 PM
  #1  
Scooterz
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Mar 2006
Location: EUGENE,OR.
Posts: 3,408
Default Regulator!!

This is strange, I installed a new regulator not so long ago (Holley BP). For some reason, it leaks a little fuel @ the adjustment bolt on top. I pulled it apart, no problems w/ the diaphram, no excess fuel in the top of regulator when I uncork the cap... WTH?? it seeps around the threads of the adustment bolt while running. Anyone had this happen?? I am running about 7lbs of pressure.
Scooterz is offline  
Old 02-04-2009, 10:43 PM
  #2  
cepx111
Senior Member
RACING JUNKIE
 
Join Date: May 2006
Posts: 2,044
Default

Can't say I've ever had that problem before, the regulator body itself must be warped, file the two halves flat with a fine mill bastard. ~Cp
cepx111 is offline  
Old 02-05-2009, 05:47 PM
  #3  
Scooterz
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Mar 2006
Location: EUGENE,OR.
Posts: 3,408
Default

Roger that CP. Thanks buddy. Scooter
Scooterz is offline  
Old 02-05-2009, 08:31 PM
  #4  
lively
Senior Member
RACING JUNKIE
 
lively's Avatar
 
Join Date: Nov 2004
Location: ILLINOIS
Posts: 2,191
Default

MAN --THE LAST TIME I USED A REGULATOR I WENT TO THE JOHN FOR 2 DAYS!!!!!!!!!!!!!!!!!!!!!
WAIT THAT WAS FOR SOMETHING ELSE ops: ops: ops: LOL LOL

LIVELY
lively is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service