1996 K1500 Z71 SEEMS SOFT SHIFTING ANY IDEAS

Old 11-22-2008, 12:02 AM
  #1  
eddie1963
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Mar 2004
Location: XENIA OHIO 45385
Posts: 107
Default 1996 K1500 Z71 SEEMS SOFT SHIFTING ANY IDEAS

1996 K1500 Z71 SEEMS TO HAVE SOFT OR SLOW SHIFTING UNLESS ON GAS MORE THAN NORMAL. WILL SHIFT GREAT IF USING A FAST TAKE OFF. UNDER NORMAL SLOW ACCLERATION SEEMS SOFT ALMOST LIKE A SLIP BUT GIVE IT MORE GAS IT TAKES OFF!!! WAS TOLD SHIFT SOLENOIDS WERE STICKING?? JUST DONT WANT TO DO MORE HARM THAN GOOD. I HAVE ALREADY FLUSHED THE TRANSMISSION NO SCREEN REPLACEMENT OR GASKET REPLACEMENT WASNT LEAKING DIDNT WANT TO START ONE. HAS ANYONE HAD THIS BEFORE OR IS IT NORMAL???? DONT WANT TO TOW WITH IT IT JUST SEEMS TO NOT RIGHT??************** TRUCK DATE CODE IS LATE 1995 *********
eddie1963 is offline  
Old 11-22-2008, 03:24 AM
  #2  
ashtrak
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: North East, Maryland
Posts: 159
Default

If it were mine i would replace the filter and reflush it. If filter has never been changed that may be your problem. That would be the cheapest fix to it before you get into the valvebody. Also you may want to adj your detent cable. Just a thought :P
ashtrak is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service