Oil pump problem?

Old 10-17-2008, 12:23 PM
  #1  
jjam
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2003
Posts: 56
Default Oil pump problem?

This is my problem, after adding 5-qts of oil 15w-40, I start to prime the pump/block I added oil in the oil filter. I started to prime with a cordless drill and battery went dead (only happens when you want to use them), I grabed the Sears 3/8 4.0amp drill and started to prime (w/shaft primer in pump) the intake is still off so I can see. The pump was turning fine, then felt the pressure, the drill started to smoke. I set the oil pump pick-up at 1/4" from the bottem of pan. Will the oil restrictors I installed in the back of the block do this? or is my pump bad, or pickup too close to pan, or needed a thinner oil? BBC 496,solid roller cam/lifters, roller rockers. Thanks I want to make sure before I install the engine in the car, Thanks again
jjam is offline  
Old 10-17-2008, 03:34 PM
  #2  
suicidebomb
Senior Member
RACING JUNKIE
 
Join Date: Jul 2007
Location: Independence, Missouri
Posts: 1,188
Default

jjam, IMO your drill is too small. I always use a 1/2 inch drill, and it drags it down. It takes a lot of power to turn an oil pump, and when you fill it with oil it gets that much harder, a 3/8 drill doesn't have the oomph required. again JMO.
suicidebomb is offline  
Old 10-17-2008, 05:30 PM
  #3  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default

Originally Posted by suicidebomb
jjam, IMO your drill is too small. I always use a 1/2 inch drill, and it drags it down. It takes a lot of power to turn an oil pump, and when you fill it with oil it gets that much harder, a 3/8 drill doesn't have the oomph required. again JMO.
I agree
hammertime is offline  
Old 10-17-2008, 06:09 PM
  #4  
jjam
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2003
Posts: 56
Default

Thanks, this will save me from taking the pan off. Thanks again
jjam is offline  
Old 10-17-2008, 07:59 PM
  #5  
fishman1
Senior Member
MASTER BUILDER
 
Join Date: Dec 2005
Location: alberta,canada
Posts: 166
Default

I always thought 3/8 clearance for the oil pump to pan
fishman1 is offline  
Old 10-19-2008, 01:31 AM
  #6  
outlaw256
Senior Member
RACING JUNKIE
 
Join Date: Mar 2008
Location: falkville al
Posts: 1,766
Default

i burnt up a old 1/2 in. drill then bought a black and wrecker. burnt that up too. i was terrified my motor was a boat anchor. bought a dewalt. still have it and my motor.
outlaw256 is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service