1150 fueling troubles

Old 09-14-2008, 07:52 PM
  #1  
kwhite4
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Mar 2004
Location: Gatesville Texas
Posts: 13
Default 1150 fueling troubles

My carb is dumping alot of fuel from the boosters into the intake at idle and up, I know there should be some but she loading up bad.
I pulled it apart and did find alittle trash but not much all else looked fine.
Any ideas this thing has me stumped.

Thanks
kwhite4 is offline  
Old 09-14-2008, 08:00 PM
  #2  
mopar1968
Senior Member
RACING JUNKIE
 
mopar1968's Avatar
 
Join Date: Dec 2006
Location: Abingdon,Virginia
Posts: 3,579
Default

How is your needles & seat's looking? what fuel pressure are you running?
mopar1968 is offline  
Old 09-14-2008, 08:11 PM
  #3  
kwhite4
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Mar 2004
Location: Gatesville Texas
Posts: 13
Default

All looked good, holds steady level in the sight hole < I set them just at the bottom of the holes, running 8 psi at the carb and 18 at the pump.
Has a aeromotive drag pump, carb is a quickfuel 1150 Dom annular boosters.
kwhite4 is offline  
Old 09-14-2008, 09:06 PM
  #4  
dparker
Senior Member
RACING JUNKIE
 
Join Date: Jun 2003
Location: Hobbs, NM
Posts: 842
Default

Turn your pressure down to 7psi. Ive seen some carbs actually spraying some fuel into the vent on your fuel block from the needle seat, causing excessive fuel to come out of the boosters. But 99% of the time its your needle seats not holding.
dparker is offline  
Old 09-16-2008, 08:23 AM
  #5  
CarbGuy
Junior Member
SHOW GUEST
 
Join Date: Aug 2008
Posts: 6
Default

If fuel is dripping out of the boosters at idle, and your float levels at in the middle of the glass you either have your butterflies open too far, or there is some dirt in the carburetor itself.
CarbGuy is offline  
Old 09-16-2008, 08:20 PM
  #6  
kwhite4
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Mar 2004
Location: Gatesville Texas
Posts: 13
Default

I ordered new needle and seats today .130 and its possible there is trash in there. I bought some VP fuel from a local dealer and found what looked like flower in it a few days after , I swear it didnt look like that when I got it ,but I caught it at the track we drained everything and replaced it.
Might have whatever that was hidden in the carb somewhere so I will pull it down and clean the crap out of it and try again.

thanks yall I will let yall know
kwhite4 is offline  
Old 09-18-2008, 07:14 PM
  #7  
mopar1968
Senior Member
RACING JUNKIE
 
mopar1968's Avatar
 
Join Date: Dec 2006
Location: Abingdon,Virginia
Posts: 3,579
Default

I run a dominator @ 7psi, i believe 8 psi will over come the seat's.
mopar1968 is offline  
Old 09-19-2008, 04:37 AM
  #8  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

I have to agree with Carbguy on this one. I'll bet the throttle blades are open too far @idle, uncovering the transfer slots, and pulling fuel through the boosters. Try backing out idle speed screw until the boosters quit dripping, then readjust idle mix. You'll probably have to slow idle speed down after mix adjustment. I had the same problem a few years back and it ran me nuts! It turned out to be just that simple.....
johnracer is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service