c4 problem ????????????? need some help

Old 08-05-2008, 06:50 PM
  #1  
eddie1963
Senior Member
SENIOR BUILDER
Thread Starter
 
Join Date: Mar 2004
Location: XENIA OHIO 45385
Posts: 107
Default c4 problem ????????????? need some help

i have a fox body mustang with a new [few weeks old] c4 transmission 2500 stall . just got car seen dated video of car running a 11.47 on and off the gas [could see shift light]at the big end. now,,,,, i have the car. at cold starts no response [ whatsoever] until it hits about 3000 rpm's. driving cold only first gear as it warms up ill get second gear then even 3rd when up to temp. by the dip stick was a bit over full, but it acted to me as if fluid was low??? [ possible wrong dip stick?] so i added a quart ran car at idle let cool off the same thing as before. the guy the car came from was surprised when i told him [ i trust this guy 100 percent] this has me baffeled. i dont want to pull it until i can somehow have an idea whats wrong? now i would guess 'if taken to the track' and ran at 'all out' this may just shift and run fine at high rpm. i have had many cars with stalls 2500 to 5500 this is not the stall working. when this trans engages its like side stepping a clutch, and reverse is same way. help help help call 937-768-0523 for eddie or leave me a message here ill be on vacation from wed til sat thank you eddie :?:
eddie1963 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service