spark plug help!

Old 07-27-2008, 02:23 PM
  #1  
finley2005
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jul 2007
Posts: 18
Default spark plug help!

i have a scott shaffiroff 406 sbc with brodix track 1 heads i am running autolite 3932 plugs are these correct!! i am having a miss above 5500 rpm. i am also running 38 degrees timing. thanks for any help!!
finley2005 is offline  
Old 07-27-2008, 04:08 PM
  #2  
hammertime
Senior Member
RACING JUNKIE
 
Join Date: May 2003
Location: Coldwater, MI
Posts: 2,998
Default Re: spark plug help!

Originally Posted by finley2005
i have a scott shaffiroff 406 sbc with brodix track 1 heads i am running autolite 3932 plugs are these correct!! i am having a miss above 5500 rpm. i am also running 38 degrees timing. thanks for any help!!
They should work or a 3910 miss above 5500 normally a plug missed all the way. Have you pulled them to make sure they look good ?
hammertime is offline  
Old 07-27-2008, 06:41 PM
  #3  
finley2005
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jul 2007
Posts: 18
Default

i have pulled them they are very sutty black! thats just from a idle not wide open throttle. i looked at them today after its been sitting for a week and they look like they have gathered moisture and a small sighn of rust! is that normal for one that has been sitting for a week without being started?
finley2005 is offline  
Old 07-28-2008, 05:16 AM
  #4  
gimmemud
Senior Member
MASTER BUILDER
 
Join Date: Apr 2006
Location: Ms.
Posts: 191
Default

If this is not a NOS engine those plugs are waayy to cold. I use AR3933 plugs with 700 hp of nos, you need to go up a couple of heat ranges.
gimmemud is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service