4L60E help

Old 07-27-2008, 11:30 AM
  #1  
jdreamin82
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Mar 2007
Posts: 2
Default 4L60E help

I have a 99 S-10 with 5.7L LS1 in it. It has a Raptor 4L60E coupled with it. A couple weeks ago, I was driving down the street and heard a loud clank, followed by some grinding. I immediately pulled over. Now, the transmission won't engage in any gear. Every gear (including Park) feels like nuetral. Any tips?? I haven't even been underneath it yet to look for myself. Work's been too crazy!!! Well, any advice would be greatly appreciated! Thanks, James
jdreamin82 is offline  
Old 07-27-2008, 01:59 PM
  #2  
Racefab57
Senior Member
DYNO OPERATOR
 
Join Date: Nov 2006
Location: NC
Posts: 558
Default

First pull the dipstick and look at the fluid! What color is it ?? Any metal?? Then drop oil pan to see if everything is in place like linkage, you never know it might be fairly simple??? GOOD LUCK, David.
Racefab57 is offline  
Old 07-27-2008, 07:05 PM
  #3  
jdreamin82
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Mar 2007
Posts: 2
Default

Yeah, I checked the fluid right off the bat. Still as red as can be, not even a hint of brown, no metal flakes, no burnt smell. Haven't dropped the pan yet, but I hope to have time tomorrow after work. Thanks, James
jdreamin82 is offline  
Old 07-28-2008, 02:41 AM
  #4  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

I'd check the rearend first since park won't hold. Fire it up, put it in gear and have a buddy look under to see if driveshaft is turning.....sounds to me like ring gear or spider gears broke.
johnracer is offline  
Old 08-05-2008, 06:17 PM
  #5  
FAT622
Member
JOURNEYMAN
 
Join Date: Apr 2007
Location: Australia
Posts: 32
Default

Had a similar problem with mine, it smashed the oil pump :x
FAT622 is offline  
Old 08-11-2008, 09:45 AM
  #6  
zerotolerance
Member
MASTER JOURNEYMAN
 
Join Date: Apr 2005
Posts: 41
Default

4l60s will break the rear planet your gona have to take the trans apart older 4l60s used a 4 gear planet the newer ones now have 5 gears. you will have to change the low reverse piston if you dont have the 5 gear planet to make it fit give me a call we stock these parts here if you need them. i have seen this several times especially when your puttin some power to a 4l60.518 505-6536 junior. hope this helps
zerotolerance is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service