Im stumped (coolant leak)

Old 07-16-2008, 10:36 AM
  #1  
rabiddawg
Senior Member
DYNO TECH
Thread Starter
 
Join Date: Aug 2007
Location: Colebrook Connecticut
Posts: 425
Default Im stumped (coolant leak)

while taking my car for a ride everything seemed fine.
upon returning I got out of the car to open garage door and parked the car.
I noticed a 1 foot puddle of coolant on the asphalt.
looking at the motor the pump and hoses all look tight but I got a steady stream of coolant dripping from the bottom middle of the timing cover.
timing cover face looked dry.
I double checked tightness of pump and the weep hole and still could not find the source.
any ideas?
rabiddawg is offline  
Old 07-16-2008, 11:26 AM
  #2  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

What type of car? If it's a sbc with a little-m block, some of the timing cover bolts go into the water jacket. They'll leak if not sealed.
Johnny
johnracer is offline  
Old 07-17-2008, 10:18 AM
  #3  
rabiddawg
Senior Member
DYNO TECH
Thread Starter
 
Join Date: Aug 2007
Location: Colebrook Connecticut
Posts: 425
Default

its a 406 smallblock chevy.
I found the problem btw.
the water pump has a small pinhole in the casting.
called edelbrock and they had bad castings in the past so they are replacing it.
rabiddawg is offline  
Old 08-04-2008, 05:54 PM
  #4  
promodjohn
Junior Member
APPRENTICE
 
Join Date: Oct 2007
Posts: 21
Default

I am fairly sure that hole in that pump casing suppose to be there,it is there to leak coolent when the pump seal is wiped.
promodjohn is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service