Dominator Dillema

Old 06-19-2008, 08:13 PM
  #1  
GLADIATORINC
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2006
Posts: 54
Default Dominator Dillema

I own a 67 Chevelle Pro Street with a 421 SBC 14:1 comp running on 111 racing gas. It's topped off with a 1050 Dominator #8896. I got the car on a trade and have been fixing all the bugs.

The fuel was set at 9psi.. but it ran. I noticed the carb linkage from the peddle to the carb was sloppy and not letting the secondaries physically open. I fixed the linkage. Started it up and had a beautiful fountain of racing fuel coming out the primaries spout. Dropped the psi to 7 and readjusted the float. I took it for a test drive. When I got on it, it bogged heavily and I had some lean pop or back fire. I got the car home just idling. I thought I had blown a powervalve.

I then took apart the carb. No powervalves. I cleaned it out and adjust the secondaries accelerator pump arm which I noticed was not touching. It was too late to start up the car and wake up my baby girl so I will try tomorrow. I will be cleaning the spark plugs cause they are fouled.

The car will see street time to local cruise nights only. I need more safety equipment to run at my local NHRA track, which will come in time. I guess I am writing to see if anyone else has had similar problems. Any suggestions?? I do have access to a 950cfm 4150, but I like seeing jaws drop when they see the Dominator. Yeah, I'm a show off.
GLADIATORINC is offline  
Old 06-20-2008, 08:06 AM
  #2  
gimmemud
Senior Member
MASTER BUILDER
 
Join Date: Apr 2006
Location: Ms.
Posts: 191
Default

Does it have electric fuel pump, if so turn the pump on do not start engine, if fuel is dripping out the boosters your float level is still too high. Also check and see what size air bleeds are in the low speed circuit.
gimmemud is offline  
Old 06-20-2008, 06:10 PM
  #4  
GLADIATORINC
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2006
Posts: 54
Default

I haven't had a chance to start up the car because of rain but I did notice the intermediate air bleeds are missing. I read on the holley website that any enlargement of the airbleeds will cause a lean condition. Which is what I experienced...I think. I will be starting the car on Saturday.

Thanks for the reading material.
GLADIATORINC is offline  
Old 06-21-2008, 06:40 AM
  #5  
jmarksdragster
Senior Member
RACING JUNKIE
 
jmarksdragster's Avatar
 
Join Date: Jul 2007
Location: Florida
Posts: 635
Default

Lets get started, first DON"T put those airbleeds in. The intermediate circuit on an 8896 makes the carb fat in the middle, lean up top or both. The intermediate circuit was designed originally for IR manifold Hemi's and while they can help in some cases, most of the time they hurt the performance. Make sure you have 93-94 jets in it. There are instances on the 8896 where you can take the jets OUT and not get one rich enough, there are idle feed tubes in the main wells that restrict the flow in some cases. If you use a powervalve (front only, never in the back) for street drivability, drop the primary jets to 88-90. Clean the carb well, making sure your idle and main airbleed passages are clean as well as the metering blocks. This should make it manageable, but the real fix is a 2-circuit conversion, read the links I posted. If you don't feel capable of doing the conversion, Gary Stinnett is one of the few doing it. Last the t-slots are usually not positioned right and too long. READ.
jmarksdragster is offline  
Old 06-21-2008, 07:01 AM
  #6  
GLADIATORINC
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2006
Posts: 54
Default

Thanks Mark. The carb currently has 91 jets. The dyno sheets I got say the 91's made the most HP...on the dyno...the street is obviously a different animal. I did read most of material. I believe I am going toward using two carbs, one for street and the other for strip.
GLADIATORINC is offline  
Old 06-21-2008, 02:34 PM
  #7  
GLADIATORINC
Member
CRAFTSMAN
Thread Starter
 
Join Date: Apr 2006
Posts: 54
Default

I started up the car today. It sounded awesome. I am still having trouble at idle. Very rough, rich, and erratic. It won't stay at a specific rpm. When I took it for a ride...Holy mother of God!!! Talk about a beast!! The car was ready to fly!!

I have come to a conclusion. I was in denial before. I own a race car with license plates. This engine has no business on the street.

Time to go racing.
GLADIATORINC is offline  
Old 06-21-2008, 07:48 PM
  #8  
jmarksdragster
Senior Member
RACING JUNKIE
 
jmarksdragster's Avatar
 
Join Date: Jul 2007
Location: Florida
Posts: 635
Default

Needs to be fixed. Are you in Florida? Otherwise tackle it or Stinnett.
jmarksdragster is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service