secondary carb problem

Old 05-25-2008, 08:30 AM
  #1  
rabiddawg
Senior Member
DYNO TECH
Thread Starter
 
Join Date: Aug 2007
Location: Colebrook Connecticut
Posts: 425
Default secondary carb problem

my carb is a holley 750 DP
primaries are good but if im cruising and punch the throttle I get some breaking up or stumble initially then itll hook up?
im thinking more pump shot or bigger shooter?
rabiddawg is offline  
Old 05-25-2008, 07:15 PM
  #2  
OneBadGMC
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: Belleville, IL
Posts: 658
Default

Lean is usually a hesitation and can even backfire out of the intake when the secondaries open until the main venturis have enough vacuum.

Fat is usually a breaking up, with black smoke and backfires out the exhaust.

You may have too much or too little accelerator pump.
OneBadGMC is offline  
Old 05-27-2008, 06:08 AM
  #3  
rabiddawg
Senior Member
DYNO TECH
Thread Starter
 
Join Date: Aug 2007
Location: Colebrook Connecticut
Posts: 425
Default

I havent noticed black smoke.
I had a problem with the primaries before and fixed it by flipping the pink cam around and readjusting the pump arm for .015 at WOT.
that gave me a huge initail pump shot then tapered off.
might aswell try that on the secondaries too.
rabiddawg is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service