Whats wrong with this picture?

Old 05-05-2008, 10:27 PM
  #1  
cepx111
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2006
Posts: 2,044
Default Whats wrong with this picture?

Ok here is a shot of the nova leaving off the line this past saturday, Been having trouble hooking up, the car is cork screwing as you can see. It feels like it is unloading the tires just after launch. The car owner swears he did nothing over the winter to this car susupension wise but the sixties have gone to the way side big time since last year and the car used to leave fairley square. The best sixty this year has been a 1.40 it used to have mid 130's What needs to be done to correct this condition? Thx in advance for any help, Charles
cepx111 is offline  
Old 05-06-2008, 04:12 AM
  #2  
cepx111
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2006
Posts: 2,044
Default

Forgot to say that the car is a ladder link set up w/ adjustable coilovers shocks. The shocks can be adjusted by change the valving with a dial on the bottom and the spring rate can be changed by moving the adjust collar up or down.
Thx again, Charles
cepx111 is offline  
Old 05-06-2008, 04:16 AM
  #3  
itsabird
Senior Member
RACING JUNKIE
 
Join Date: Dec 2007
Location: ohio
Posts: 812
Default

what kind of shocks ,and springs, do you have on the rear?
itsabird is offline  
Old 05-06-2008, 06:30 AM
  #4  
sp2816
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: Owingsville, Ky
Posts: 157
Default

Charles,

It could be that the slicks got hard over the winter and have gone bad to cause the 60fts to go away. But, it does appear that there is too little air in the slicks from all of the sidewall wrinkles on the launch. That could cause it to bounce a little after the launch and then maybe spin. You might also want to make sure that the shocks have the same settings, as maybe one was bumped or turned over the winter.

As far as the twisting, I would check the pre-load of the ladder bars by jacking up the front end of the car in the exact center. I use a smaller floor jack and you can even put a piece of pipe on its side from front to back to have the smallest amount of surface area on the front frame. I jack the car up until both front wheels are off of the ground (if limiters are on the front make sure that both a-arms move the same). I then adjust the pre-load until both front tires are the same amount off of the ground (this would actually be zero pre-load). If the drivers side is twisting up on the launch with it at zero pre-load, then I adjust the pre-load until the drivers side tire is lower by 1/2 inch than the passenger side tire (that would actually be about 1/4 inch pre-load because the passenger side will go up by the same amount as when the drivers side is adjusted down), and so on.

If you check the front suspension and pre-load on the car right now and it is at zero, then you might have a bad shock on the passenger side rear. It could have leaked or gotten air bubbles. You can change the shocks from side to side for a test.

Good luck,
Bill Mitchell
sp2816 is offline  
Old 05-06-2008, 08:11 AM
  #5  
tazracing
Senior Member
SENIOR BUILDER
 
Join Date: Mar 2003
Posts: 107
Default

WHAT KIND OF REAR IS IN IT? I THE SAME THING HAPPEN. I HAVE 12 BOLT WITH FOUR LINK. I HAD TWO PEOPLE ADJUST THE CAR AND THE SAME THING HAPPENED. THEN I HAD SOMEONE SCALE THE CAR AND HE FOUND THAT AXLE TUBES WERE TWISTING. WE WELDED THE TUBE ALL THE WAY AROUND AND MADE NEW PLUG WELDS .NOW IT GOING STRAIGHT EVERY TIME AND IM BACK TO 1.29 60 FT.
tazracing is offline  
Old 05-06-2008, 11:46 AM
  #6  
bbb555
Member
JUNIOR BUILDER
 
Join Date: Aug 2003
Location: columbus,ohio
Posts: 93
Default

Originally Posted by sp2816
Charles,

It could be that the slicks got hard over the winter and have gone bad to cause the 60fts to go away. But, it does appear that there is too little air in the slicks from all of the sidewall wrinkles on the launch. That could cause it to bounce a little after the launch and then maybe spin. You might also want to make sure that the shocks have the same settings, as maybe one was bumped or turned over the winter.

As far as the twisting, I would check the pre-load of the ladder bars by jacking up the front end of the car in the exact center. I use a smaller floor jack and you can even put a piece of pipe on its side from front to back to have the smallest amount of surface area on the front frame. I jack the car up until both front wheels are off of the ground (if limiters are on the front make sure that both a-arms move the same). I then adjust the pre-load until both front tires are the same amount off of the ground (this would actually be zero pre-load). If the drivers side is twisting up on the launch with it at zero pre-load, then I adjust the pre-load until the drivers side tire is lower by 1/2 inch than the passenger side tire (that would actually be about 1/4 inch pre-load because the passenger side will go up by the same amount as when the drivers side is adjusted down), and so on.

If you check the front suspension and pre-load on the car right now and it is at zero, then you might have a bad shock on the passenger side rear. It could have leaked or gotten air bubbles. You can change the shocks from side to side for a test. I had the same problem you speak of and did about the same thing Bill say's to do. I have a ladder bar 72 nova and I got it hooking pretty good with a 1.31 60 ft by doing what bill said.

Good luck,
Bill Mitchell
bbb555 is offline  
Old 05-06-2008, 08:06 PM
  #7  
cepx111
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: May 2006
Posts: 2,044
Default

Slicks are new 31x10.5w only 2 weekends.
The rearend is a big ten minitubbed. I was running 12 to 11.5 psi last weekend, I used to be able to run slighty lower like 10.5 to 9.5 but when I do that it really spins.
Not sure what brand the shocks and springs are, I'll try swapping the shocks from side to side this weekend and see what happens, Thx for the replies.
>Charles
cepx111 is offline  
Old 05-07-2008, 08:47 AM
  #8  
itsabird
Senior Member
RACING JUNKIE
 
Join Date: Dec 2007
Location: ohio
Posts: 812
Default

swapping shocks around is good idea, i had same prob, with a set of comp-eng single adj, shocks. imo, most ladder bar cars that are close to the sweet spot, seem to hit the tires pretty hard, sometimes a little to hard, if you do not have double adj, and can not stiffen rebound, you can sometimes compensat for this condition by increaseing tire pressure, i would make sure the shock was bad first. if so and you can swing it, go double adj. i have 4 link, they helped me eliminate the hook, unhook condition, poor track conditions also, good luck with test.
itsabird is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service