Torque Converter Failed? / broken pieces inside

Old 04-08-2008, 11:16 PM
  #1  
caprice327
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Dec 2007
Location: Utica Michigan
Posts: 16
Default Torque Converter Failed? / broken pieces inside

Durring a good burnout / launch I was holding at 7000 rpm for about 5 seconds when this extreamly loud metal screech sound occured then no more forward and only a slight amount of reverse.

Pulled the tranny (th350), brand new 1 day old fluid had that horrible burnt smell and the stall was full of metal shavings and chunks. I think the turbines in the stall failed.

If so what are the chances that the transmission will have to be torn down?
I was hoping to flush it out and get a new stall
caprice327 is offline  
Old 04-09-2008, 03:44 AM
  #2  
johnracer
Senior Member
DYNO OPERATOR
 
Join Date: Aug 2005
Location: Rifle Colorado
Posts: 585
Default

You'll need to tear down and clean the trans, and replace the cooler. You won't get all the crap out by flushing. Not even close. Save yourself some aggravation and just do it....
johnracer is offline  
Old 04-09-2008, 04:57 AM
  #3  
us7race
Senior Member
EXPERT BUILDER
 
Join Date: Aug 2005
Location: Tell City, IN
Posts: 356
Default

I think something let go in the trans. I have broken a converter in the burnout and had no movement in any gear. Still had to tear the trans down for clean-up. JMO.
us7race is offline  
Old 04-09-2008, 05:14 AM
  #4  
performanceengin
Member
JUNIOR BUILDER
 
Join Date: Oct 2005
Location: ohio
Posts: 94
Default

sounds like a tear down. also check the sprag to make sure it didn't go out. it will shoot converter full off metal when it goes out.
performanceengin is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service