350 sbc ring problem???????

Old 03-18-2008, 09:38 AM
  #1  
HUNTER39
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Nov 2007
Posts: 28
Default 350 sbc ring problem???????

I am installing a new set of rings, standard bore, only thing different is that the cylinders was honed. I have used 2 different set of rings and the oil rings are to tight to fit in the bores. piston goes right in with comp rings. I also cleaned ring grooves with no luck. Any Ideas?
HUNTER39 is offline  
Old 03-18-2008, 11:46 AM
  #2  
billhendren
Senior Member
MASTER BUILDER
 
Join Date: Dec 2005
Location: Rutherfordton North Carolina
Posts: 192
Default

Did you check the oil ring end gap? the rails may be butting.Bill
billhendren is offline  
Old 03-18-2008, 11:49 AM
  #3  
HUNTER39
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Nov 2007
Posts: 28
Default ring gap

yes approx .025 oil ring gap
HUNTER39 is offline  
Old 03-18-2008, 12:02 PM
  #4  
gimmemud
Senior Member
MASTER BUILDER
 
Join Date: Apr 2006
Location: Ms.
Posts: 191
Default

Make sure you have the correct radial thickness ring for your piston, in other words the ring could be thicker than the groove is deep.
gimmemud is offline  
Old 03-18-2008, 12:13 PM
  #5  
HUNTER39
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Nov 2007
Posts: 28
Default problem solved

in 87-88 they made a shallow groove pisto and the standard deep groove we have the shallow groove. Thanks for your input
HUNTER39 is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service