What do you guys think

Old 02-18-2008, 01:18 PM
  #1  
rsrsfishslayers
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Feb 2007
Location: Sweethome, OR
Posts: 133
Default What do you guys think

I just put on the tunnel ram and a new cam. I took it for a ride and drove it about 30 miles I was at a stop light and went to take off and it acted kike I fouled out all the plugs. It did not run good at all I just got it home it was poping when I put on the gas. I put new plugs in and checked the distributor cap it all looks good no cracks. I am a driver not a mechanic It was all I could do to change the pulgs. So what do you guy think. After reading this I sould tell you I had help with the tunnel ram and cam ops: ops:
Thank you for any help
CPT.RON
rsrsfishslayers is offline  
Old 02-18-2008, 03:14 PM
  #2  
olds48
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: Montvale, VA
Posts: 1,431
Default

What did the plugs look like when you pulled them?Are you sure the needle and seat are clean in your carb?If it was running fine then all of a sudden started loading up,might be needle and seat leaking or trash in the bowl preventing them from closing.Are you running fuel filters?
olds48 is offline  
Old 02-18-2008, 03:24 PM
  #3  
lookingaround
Senior Member
RACING JUNKIE
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default

did the distributor turn on you?
lookingaround is offline  
Old 02-18-2008, 03:59 PM
  #4  
rsrsfishslayers
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Feb 2007
Location: Sweethome, OR
Posts: 133
Default

The plugs looked ok they were dark and I have a glass filter inline I took it off and the was some junk in it they are edelbrock carbs I am thinking that I may have got some stuff in them can you tell how to clean them out.
Thank you
CPT.RON
rsrsfishslayers is offline  
Old 02-18-2008, 06:11 PM
  #5  
olds48
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: Montvale, VA
Posts: 1,431
Default

Try to wipe the junk out with a rag and some carb cleaner(Walmarts Super tech carb cleaner is the best and cheapest).Might have to take them off and flip them upside down so you can rinse them out real good.I think the Edelbrocks you have to take the whole top off to get to the bowls.It's not hard to do though,you'll be OK.Make sure the floats aren't leaking,but I don't think that's your problem.Are the glass filters the Mr Gasket type?If you over-tighten them it will distort the filter element inside and the trash will go right into the bowls.They aren't as pretty but I just use the standard el-cheapo paper element filters,never failed me yet.BTW super tech carb cleaner will remove any paint and dissolve almost any plastic in touches.Watch the overspray!I'd hate to see your car's paint get screwed up
olds48 is offline  
Old 02-18-2008, 10:59 PM
  #6  
cepx111
Senior Member
RACING JUNKIE
 
Join Date: May 2006
Posts: 2,044
Default

Oh no the dreaded eldebrock performer carb sydrome, sounds like they loaded up the plugs if they are black, might as well toss them and buy another set dont try cleaning them its a awaste of time.
Question do you have a ignition box? I.E> MSD 6AL.
If you dont you need one, will help a bunch.
When you replace the plugs check the gaps make sure their not over .035 then when you get in running check ignition timing make sure the distibutor hasnt slip on you. With the trash in the fuel filter as you described you might have very well gotten some trash in the carb and got your needle and seat clogged so it wouldnt seat properly, also you could have some trash in the main jets which will make it run terrible too, either way you'll have to remove the tops off the carbs, no biggie and clean them as required. Keep us updated
Goodluck, Charles
cepx111 is offline  
Old 02-19-2008, 03:40 PM
  #7  
rsrsfishslayers
Senior Member
MASTER BUILDER
Thread Starter
 
Join Date: Feb 2007
Location: Sweethome, OR
Posts: 133
Default

Thanks to all for the help. Found it out to be a clogged carb. Cleaned them out and runs good. I still need to have it fine tuned but it is running.. Thanks to all you guys. If it wasn't for guys like you I would stay a driver all my life and not learn how to work on what I am driving. Whether it be the 29, the race car or just the family car.
Thanks to all.
CPT.RON :P :P :P :P
rsrsfishslayers is offline  
Old 02-19-2008, 04:01 PM
  #8  
lively
Senior Member
RACING JUNKIE
 
lively's Avatar
 
Join Date: Nov 2004
Location: ILLINOIS
Posts: 2,191
Default

Originally Posted by rsrsfishslayers
Thanks to all for the help. Found it out to be a clogged carb. Cleaned them out and runs good. I still need to have it fine tuned but it is running.. Thanks to all you guys. If it wasn't for guys like you I would stay a driver all my life and not learn how to work on what I am driving. Whether it be the 29, the race car or just the family car.
Thanks to all.
CPT.RON :P :P :P :P
YOU KNOW YOU REALLY ARE A NICE GUY [NO MATTER WHAT OLDS48 SAID ABOUT YOU]--WAIT A MINUTE I SHOULDN'T HAVE SAID ANYTHING ops: ops: ------LOL LOL---- LIVELY :lol: :lol: :lol:
lively is offline  
Old 02-20-2008, 02:13 PM
  #9  
olds48
Senior Member
RACING JUNKIE
 
Join Date: Sep 2007
Location: Montvale, VA
Posts: 1,431
Default

Glad you got it fixed Captian Ron!I like your style,man.You just get on here and say,"hey,how do I fix this thing?",unlike some of the guys who are trying to impress someone with all their knowledge.Way to go,man.If you can break,you can fix it!
olds48 is offline  
Old 02-20-2008, 02:28 PM
  #10  
v8Fiero
Senior Member
MASTER BUILDER
 
Join Date: Nov 2007
Location: Wisconsin cheesehead!!
Posts: 213
Default

thats what a project car is all about... breaking, fixing and learning as you go. I dont care how old you are, you learn something new everyday and we all have to start somewhere. 8)

if you ever get overwelmed with the 29, I wouldnt mind taking it off your hands for you! :wink:
v8Fiero is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service