Header Problem?

Old 11-05-2007, 04:55 AM
  #1  
StrokedBBC
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jan 2007
Location: Mid Michigan
Posts: 18
Default Header Problem?

I'm building a 505ci. BBC for my 74 Nova i'm useing Pro Top Line iron 320s the exh. ports are raised .500" am i going to run into problems when it's time to buy headers?
StrokedBBC is offline  
Old 11-05-2007, 05:04 AM
  #2  
bjuice
Administrator
RACING JUNKIE
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

i would Say bolting to the heads ..NO...but clearance from there down who knows..
many of us has seen headers that suppose to clear chassis that do not ( off shelf).

good luck and lets hope you do not have to go with custom header work.

Nothing left to do but try what you have,

thanks
bjuice is offline  
Old 11-06-2007, 08:02 AM
  #3  
RonOwensRacing
Senior Member
DYNO OPERATOR
 
Join Date: Oct 2004
Location: florence ky
Posts: 498
Default

I ran those heads on a 572 in my nova i used hooker super comps they fit good no problem it was a 73 same car.
RonOwensRacing is offline  
Old 11-07-2007, 10:54 AM
  #4  
StrokedBBC
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Jan 2007
Location: Mid Michigan
Posts: 18
Default

Thanks for the info i appreciate it. Did you run aluminum or iron Pro Top Line heads? How did your 572 run? My 505 is getting there i have the short block together, heads are assembled, when i get some time i'll get back out there i have to measure and see what length pushrod i need.
StrokedBBC is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service