Steve Howard 706 57 chevy.

Old 08-25-2007, 09:17 PM
  #1  
bjuice
Administrator
RACING JUNKIE
Thread Starter
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default Steve Howard 706 57 chevy.





Steve is my cousin..My wife took these pics and i was there..the date on the camara is wrong pics were taken 8/19/07. this is full tube car 2500lbs with driver,Fulton 706 ci with 2 stages..made 1400 hp on motor and over 1100 ft lbs TQ.....He will be running the same class i will be running in my vette...he has 200 more raw HP more than me but i have him by nearly 300 lbs..
no weight restrictions in this class..only rules are no lenco's or bruno's and you cannot run lower than 4.70.....
this car is bad to the bone..it has a 18x34.5 wheel tucked under with plenty of clearance....

Brian
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 08-26-2007, 04:47 AM
  #2  
ashtrak
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: North East, Maryland
Posts: 159
Default

This looks like the start of some good compitition for two cousins on the same track and class so hopefully when one does lose you'll have extra hands in the pit area for support
ashtrak is offline  
Old 08-26-2007, 05:44 AM
  #3  
woodsman
Senior Member
DYNO OPERATOR
 
Join Date: Mar 2007
Location: Texas
Posts: 525
Default

Brian after you let me run that vette maybe he will let me run that 57. That is a sweet ride.
woodsman is offline  
Old 08-26-2007, 11:43 AM
  #4  
bjuice
Administrator
RACING JUNKIE
Thread Starter
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

LOL...will do.....he's a great guy...


later guys...Brian
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 08-27-2007, 06:20 AM
  #5  
mcracecars
Senior Member
EXPERT BUILDER
 
Join Date: Dec 2006
Posts: 272
Default

those pics do not show up on my computer??
mcracecars is offline  
Old 08-27-2007, 12:53 PM
  #6  
lively
Senior Member
RACING JUNKIE
 
lively's Avatar
 
Join Date: Nov 2004
Location: ILLINOIS
Posts: 2,191
Default

it showed on mine the first day you posted but not since then----LIVELY
lively is offline  
Old 08-27-2007, 04:34 PM
  #7  
chevguy65
Senior Member
RACING JUNKIE
 
Join Date: Sep 2005
Location: ID
Posts: 1,125
Default

I am not seeing them either, and your avatar is a red x as well.

It happens, believe me.
If it is the same thing that happened to me you will have to upload them again and re-post them.
chevguy65 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service