1979 Mercury Capri RS Won't Crank

Old 07-06-2007, 06:58 PM
  #1  
lotsof454sss
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2006
Location: North Georgia "GODS COUNTRY"
Posts: 539
Default 1979 Mercury Capri RS Won't Crank

I am having a problem ...The car will crank and run fine and you can drive anywhere but when I come back out it will not start...It turns over fine but no go...After it sits all night it will crank no problem...I have replaced the coil and the ignitor and didn't help, then the switch didn't help and then the module right below the switch and it cranked, but after I drove it a little while it would not crank...Last time it did this I checked and the coil and ignitor were real hot to the touch, almost would blister you..I have "not" replaced the distributor and that is the last part remaining I think..Could it be a bad pickup...and I do not mind replacing the distributor as it is only $52 but hate to if not needed...and mostly I hate to and it not be the cure....Any input appreciated..Oh yea, when it is in the no crank mood you can turn over the engine to no avail but when you release the key and the switch returns to the "on" position you can tell it tries to crank for just an instant but of course will not continue to run....
lotsof454sss is offline  
Old 07-09-2007, 04:44 AM
  #2  
gimmemud
Senior Member
MASTER BUILDER
 
Join Date: Apr 2006
Location: Ms.
Posts: 191
Default

Sounds like the magnetic pickup in the distributor to me, I had one give me headaches for weeks until I replaced it, after replacing everything else first. :twisted:
gimmemud is offline  
Old 07-09-2007, 04:07 PM
  #3  
lotsof454sss
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2006
Location: North Georgia "GODS COUNTRY"
Posts: 539
Default

Did yours make the coil get real hot :?: I had a distributor do sort of like this in a 83 Chevy pickup once too, so I think it may be time for the distributor...Thanks for the input by the way......Would like to have some other opinions also, so come on guys
lotsof454sss is offline  
Old 07-09-2007, 04:55 PM
  #4  
lookingaround
Senior Member
RACING JUNKIE
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default

sent ya a pm perry
lookingaround is offline  
Old 07-20-2007, 09:52 AM
  #5  
lotsof454sss
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2006
Location: North Georgia "GODS COUNTRY"
Posts: 539
Default

Got a new pickup coil today and going to install and also replacing the ignitor pack just to confirm it is good...Both pieces were less than 50 bucks sooooooooo let ya know later
lotsof454sss is offline  
Old 07-25-2007, 04:53 PM
  #6  
lotsof454sss
Senior Member
DYNO OPERATOR
Thread Starter
 
Join Date: Apr 2006
Location: North Georgia "GODS COUNTRY"
Posts: 539
Default

Well replaced the whole distributor and ignitor pack and all seems fine..Am now waiting on the next owner to come and get it unless he has backed out and if so I am glad and going to raise the price another $500 because it is such a nice car and I have not seen any around quite like this one...
lotsof454sss is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service