700R ?

Old 07-05-2007, 05:52 AM
  #1  
chevguy65
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Sep 2005
Location: ID
Posts: 1,125
Default 700R ?

I accidently overfilled my tranny and drove it for about 30 miles.

Could the overfill damage the trans?

It seems fine, but just wanted to know the issues if any of overfilling it.

Drained it down to the proper level.

Just got in a hurry and didn't heat it up properly before I checked it.
I have a tiny leak at the speedo cable and need to replace the o-ring in it.


TIA
chevguy65 is offline  
Old 07-06-2007, 06:43 PM
  #2  
bjuice
Administrator
RACING JUNKIE
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

Most of the time it will blow it out of the vent tube ..i do not think you hurt anything..

i have done this myself before with NO collateral damage.

bJUICE
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 07-06-2007, 08:06 PM
  #3  
lookingaround
Senior Member
RACING JUNKIE
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default

i think the most it will do is blow the front or rear seal. im sure there is someone that will correct me if im wrong.
lookingaround is offline  
Old 07-06-2007, 10:08 PM
  #4  
chevguy65
Senior Member
RACING JUNKIE
Thread Starter
 
Join Date: Sep 2005
Location: ID
Posts: 1,125
Default

Originally Posted by lookingaround
i think the most it will do is blow the front or rear seal. im sure there is someone that will correct me if im wrong.
No thats just ice cream :shock: :P :P :P


Seriously, thanks guys... :wink:
chevguy65 is offline  
Old 07-16-2007, 09:38 PM
  #5  
mountie
Junior Member
SHOW GUEST
 
Join Date: Jul 2007
Posts: 7
Default Re: 700R ?

Originally Posted by chevguy65
I accidently overfilled my tranny and drove it for about 30 miles.

Could the overfill damage the trans?

It seems fine, but just wanted to know the issues if any of overfilling it.

Drained it down to the proper level.

Just got in a hurry and didn't heat it up properly before I checked it.
I have a tiny leak at the speedo cable and need to replace the o-ring in it.


TIA
A 700R either runs fine, or it's screwed up. If it runs fine, your tranny is fine. Make sure the throttle valve cable adjustment is correct. That's the #1 killer of 'em, after heat.
mountie is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service