powerglide ?'s

Old 06-04-2007, 06:21 PM
  #1  
CHEVYMATT
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Nov 2004
Posts: 91
Default powerglide ?'s

hey guys
i just purchased a powerglide with 1.76 shaft and manual valvebody i think.. it has a valvebody separator plate that says powerglide b and says tci on it.. it also has a plug in valvebody where modulator goes as well as modulator external hole pluged. it has a 30 spline input that is 12 7/8 long and is removable. does any of this sound good . is there anything to look at to tell if its good or bad. thank you
CHEVYMATT is offline  
Old 06-05-2007, 07:18 AM
  #2  
sp2816
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: Owingsville, Ky
Posts: 157
Default

All powerglides have the removable input shaft, but with it having 30 splines that means that it is to be used with the T350/T400 torque convertors and that it is an aftermarket and stronger shaft. It does sound like you do have a manual valve body kit in it. The other item that it should have with those mods would be a steel hub inside the front clutch drum instead of the cast steel that is stock. The 1.76 planetaries are the stronger ones from stock.

Your question "does any of this sound good?" really depends on how much you paid and are expecting out of the transmission, but those are the basic upgrades to make it live. Other items that could have added would be a Kevlar band or a dual ring servo piston, but I doubt that it has those mods.

Your next question "is there anything to look at to tell if its good or bad?" do you mean physically bad? That would be clutch material in the pan or burnt fluid. Or chipped teeth in the planetaries. If it has set for a lot of years, the seals could be getting hard, so a basic rebuild could be in order with new clutches and seals.

Bill M
sp2816 is offline  
Old 06-05-2007, 04:50 PM
  #3  
CHEVYMATT
Member
JUNIOR BUILDER
Thread Starter
 
Join Date: Nov 2004
Posts: 91
Default

thanks bill
im hoping it,s a decent trans. it has a 12.7/8 long input shaft so i was told it's a 1.76 but im not sure . there is a tci manual valebody in it as well as some other odds and ends like all the shifting levers and parking pawl are all tci. how do i know if it has a turbo bushing in it.the turbo shafts fits with a little play around bushing. i also looked at the servo and it is a single ring servo.it has a 30spline turbo shaft for sure. i just want it to hold up to street strip with about 600hp and in a s-10 with 4.88 gear. well any help is greatful thank you
CHEVYMATT is offline  
Old 06-05-2007, 10:41 PM
  #4  
sp2816
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: Owingsville, Ky
Posts: 157
Default

When the turbo bushing is installed, the end of the front pump stator is machined and it is installed in the end. So, you should be able to see it when you pulled the input shaft out. I have not run that bushing, and have yet to have a problem.

On the shifter lever, make sure that you have the correct one for the type of shifter that you are using. Some have 2 holes, one for the B&M and one for the Hurst. Others just have a single hole. I had to purchase a completely different lever for the QuarterPro shifter.

The reason that I suggest the dual ring servo is because in 1st gear fluid pushes in on the servo and applies the band. But when you shift to high gear, the fluid pushes on the inside of the servo to disengage the band and also applies the high gear clutches. If the servo ring leaks too much, you can lose pressure to the clutches. You should be able to get by without it, but it is a minor upgrade.

It sounds like you have a good core transmission, and if the clutches and seals are good it should give you some good service. Just make sure about the clutch hub.

Bill M
sp2816 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service