Powerglide overheating

Old 05-24-2007, 10:18 AM
  #1  
TEDKORPI
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Apr 2007
Posts: 9
Default Powerglide overheating

I am new to racing and have a powerglide that i think gets to hot. After one run its at 200 let it cool to 160 and it will go to 220 after the next run. It has a cooler on the firewall in a 2100 lb car with a 502 i have type f fluid in it is this normal or a problem. Can anyone help? THANKS
TEDKORPI is offline  
Old 05-24-2007, 10:41 AM
  #2  
sp2816
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: Owingsville, Ky
Posts: 157
Default

The temperature does seem to be getting a little too hot (from 160 to 220 on one run), but a lot of heat build up usually comes from the torque converter slipping too much. What stall is your converter and how much does it seem to be slipping with the big block? What is the size of the cooler on the firewall? (I have mine mounted about 2" away from the firewall and it is 15x7) Make sure that the cooler isn't clogged or that the lines aren't pinched or clogged. (I run #6 steel braid line for mine) Do you have the deeper aluminum pan? This will add strength to the case and also 2 extra quarts. What size converter do you have and how long are you "on" the converter before making your run? (I don't floor my car and go onto the 2-step until the 2nd yellow goes out.)

Bill M
sp2816 is offline  
Old 05-24-2007, 11:49 AM
  #3  
TEDKORPI
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Apr 2007
Posts: 9
Default POWERGLIDE OVERHEATING

I have only made two 400 foot runs. I have a 9 inch converator that is new with 6000 stall and 7200 shift chip. I am not sure how much the converter was slipping the tires were spinning most of the way and i dont have a good feal of it yet. I let the lights come on and trans braked it less than two seconds. I have a deap pan holds about 9 quarts i think. Cooler is 15x8 with but is is mounted on the wall and i will pull it to see if it is clean. Thanks for your info. Ted
TEDKORPI is offline  
Old 05-24-2007, 12:16 PM
  #4  
sp2816
Senior Member
MASTER BUILDER
 
Join Date: May 2003
Location: Owingsville, Ky
Posts: 157
Default

6000 stall is pretty loose, so it will build a lot of heat. But with 400ft runs it still shouldn't get that hot and it doesn't sound like you are on the converter too long to build that much heat. Check to make sure that the lines aren't getting heated by a header.
I know it all goes pretty quick, especially in a new combo, but try to see what the rpm's come down to after the shift at 7200. They should come down close to the 6000 and then start pulling up again.

Good luck,
Bill M
sp2816 is offline  
Old 05-24-2007, 12:35 PM
  #5  
lookingaround
Senior Member
RACING JUNKIE
 
Join Date: Feb 2006
Location: Lenoir City Tennessee
Posts: 865
Default

id try moving the cooler out in front of the radiator so it can get cooler air.instead of all the heat in the motor compartment.jmo
lookingaround is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service