400th problems

Old 04-20-2009, 06:41 PM
  #11  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

There is nothing wrong with a th400, it sucks your haveing a small problem that is eating your lunch. A glide would works wonderfully in ur case thou
kwkracing is offline  
Old 04-21-2009, 09:16 AM
  #12  
hvychvy
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: May 2007
Location: Pfafftown , NC
Posts: 28
Default

I think my tranny guy is really close to fixing the problem, he left a message on my cell that he'd taken it apart about three times checking tolerances and such shouyld get it back this week. I turn this sbc about 7000 give or take 200 rpm , rev limit at 7400. In case this 400 doesn't work I'm pricing glides ATI or COAN looking good for price and reputation.Thanks for all the replies guys.
hvychvy is offline  
Old 05-29-2009, 03:15 PM
  #13  
Racefab57
Senior Member
DYNO OPERATOR
 
Join Date: Nov 2006
Location: NC
Posts: 557
Default

Im prpbably not suppose to do this BUT, give me a call or email me Im dealing with Trans Specialties stuff(GLIDES ) and have great luck with their stuff!DR.
Racefab57 is offline  
Old 06-02-2009, 07:21 AM
  #14  
CamBirdRacing
Senior Member
DYNO OPERATOR
 
Join Date: Feb 2009
Posts: 510
Default

I have a TS convertor and love it.
CamBirdRacing is offline  
Old 06-03-2009, 10:19 PM
  #15  
cepx111
Senior Member
RACING JUNKIE
 
Join Date: May 2006
Posts: 2,044
Default

Originally Posted by CamBirdRacing
I have a TS convertor and love it.
Me too, a 8 inch spragless.
cepx111 is offline  
Old 06-04-2009, 06:41 PM
  #16  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

Well how is the th400 coming?
kwkracing is offline  
Old 06-06-2009, 11:59 AM
  #17  
hvychvy
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: May 2007
Location: Pfafftown , NC
Posts: 28
Default

I am not going to give up on the 400, I put it back in this last time and we hooked a pressure gage to it. When I put it in reverse on jack stands at the gage jumped from really low pressure to almost pegging the gage probably about 260 psi, in all 3 forward gears was at about 190psi and would drop at the shift slightly and go back to 190. Idon't know why but he put a modulator on the tranny, he saiid something about having a little backpressure?????? I do know that modulator is leaking tranny fluid really close to my exhaust, so right now I'm going to do what I should have done to start with and buy a glide with a turbo input, and try to eventually get this 400 fixed. The tranny guy said we'll try a valve body next,then the pump, when I do get this 400 right it'll just be a backup tranny I guess or a doorstop or something got too much $$$ in the damn thing not to get some use out of it.
hvychvy is offline  
Old 06-06-2009, 08:59 PM
  #18  
kwkracing
Senior Member
RACING JUNKIE
 
Join Date: Dec 2004
Location: austin texas
Posts: 729
Default

Are you sure the vent above the modulator is not whats leaking?

You might have a bad case. The case where the bolt goes threw the valve body side and into the center support may be wallered out, allowing the bolt to bottom out in the center support, appearing to be tight but the whole assembly is really loose in the case?

Where are you located?

How heavy is you vehicle?
kwkracing is offline  
Old 06-07-2009, 05:08 AM
  #19  
hvychvy
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: May 2007
Location: Pfafftown , NC
Posts: 28
Default

I am in N. Carolina close to Winston-Salem , and it's an 1983 s-10 probably 2800-2900 lbs.
hvychvy is offline  
Old 06-07-2009, 05:19 AM
  #20  
hvychvy
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: May 2007
Location: Pfafftown , NC
Posts: 28
Default

Yes I'm sure its coming from the modulator. I've got to get a glide before this racing season glides right on by me. I will get this 400 fixed if I have to replace the valve body, pump or even the whole case, the leak is just keeping me from running it or leaning on it at all. I guess on my next days in the shop I'll try and fix the leak. Then I can take it back to T&T at the track , as I said in an earlier post this last incarnation shifted on the jack stands just had crazy pressures in reverse , Iam worried it will eat itself again.
hvychvy is offline  

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service