please help its getting costly

Old 06-04-2008, 09:35 AM
  #1  
gpracer
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Aug 2005
Posts: 29
Default please help its getting costly

this is the problem i keep have happening breaking transmission this is the second time the motor has solid mounts and trans a polyurethane mount just had driveshaft balanced and its good any help would be great i can only afford to do 1 more trans if it breaks i am done racing for the year the car is a 78 camaro i also had an 8 point cage put in what else needs to be done i am lost on this thanks for your input on this :?
gpracer is offline  
Old 06-04-2008, 11:07 AM
  #2  
john858
Senior Member
EXPERT BUILDER
 
Join Date: Jan 2007
Location: atwood,Ky
Posts: 302
Default

need more info what are you breaking on or in the trans ,is your frame tied, are your front frame mounts good,are you using same gearset,any viberating before,what kind of trans. what gearset.
john
john858 is offline  
Old 06-04-2008, 11:21 AM
  #3  
gpracer
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Aug 2005
Posts: 29
Default

we are breaking the trans case right before the pump frame is tied and a 456 gear
gpracer is offline  
Old 06-04-2008, 11:22 AM
  #4  
gpracer
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Aug 2005
Posts: 29
Default

turbo 350 we have had no problems with this until we put in the new motor its a 388 chevy
gpracer is offline  
Old 06-04-2008, 11:27 AM
  #5  
john858
Senior Member
EXPERT BUILDER
 
Join Date: Jan 2007
Location: atwood,Ky
Posts: 302
Default

cause you are breaking cases i would check your sub-frame mounts in the front of the car ,you might have to go to solid frame mounts in to stop the front of the car from flexing.good luck
john858 is offline  
Old 06-04-2008, 12:30 PM
  #6  
gpracer
Junior Member
JOURNEYMAN
Thread Starter
 
Join Date: Aug 2005
Posts: 29
Default

thanks john we were thinking about doing that thanks again
gpracer is offline  
Old 06-04-2008, 02:29 PM
  #7  
tkilby
Junior Member
APPRENTICE
 
Join Date: Nov 2005
Posts: 16
Default

IMO, Front Motor Plate, Mid Plate, Lateral Engine Travel Limiters!
tkilby is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service