broken th350 bellhousing

Old 11-22-2007, 06:15 PM
  #11  
SST4530
Senior Member
DYNO TECH
 
Join Date: Feb 2004
Location: Leonard, Texas
Posts: 414
Default

Well I don't think it should be cracking the bell housing in the first place. I've been racing for 25 years and never busted a trans case. You've got a real problem if you are. Do you have sub frame connectors or a roll cage? Sounds to me like you have way to much chassiss flex along with not enough flexibility in the mounts.

If go to an ultra bell you may still brake something just in a different location, so your just covering up the problem and transfering it to the next weakest link. Just my $.02
With soild mounts and rear rubber mount, you must be getting alot of chassiss twist to bust the case. have afew questions:

1. How much converter are you running?
2. Transbrake?
3. Slicks?

I think you need a cage, front strut tubes and cross bar to stiffen this thing up. Just my $.02 :wink:
SST4530 is offline  
Old 11-22-2007, 06:27 PM
  #12  
sgblazer2
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Nov 2007
Posts: 14
Default

the stall is a 2000, iknow its needs more with the 292/292 duration cam, no trans brake and 28/12.5-15 mt et street.
sgblazer2 is offline  
Old 11-22-2007, 06:47 PM
  #13  
lanham
Senior Member
MASTER BUILDER
 
Join Date: Dec 2005
Location: berea,ky
Posts: 184
Default s-10

I used to have a long wheelbase s-10 that i put a 350 engine in.It was a street truck.Before i got the problems out of it i busted two bellhousings on it.Before it busted the bellhousings it had a bad vibration in it.The only things that i found was the tip of the bellhousing was touching the firewall and the starter was tight against the frame(very little clearance) and was a stock size starter.I clearanced both areas and i had been running a one piece driveshaft,(it destroyed both of those too) and after the clearancing i went back with the stock two piece driveshaft.After that i had no more vibration and no more problems.I had stock motor mounts and tranny mount.Just giving you something else to look at.This truck ran 13.40s in the 1/4 so it wasn't no big high horsepower deal.
lanham is offline  
Old 11-22-2007, 07:13 PM
  #14  
sgblazer2
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Nov 2007
Posts: 14
Default

thank lanham. my best time with all the problems was 9.146 in the 1/8
sgblazer2 is offline  
Old 11-23-2007, 06:26 AM
  #15  
bjuice
Administrator
RACING JUNKIE
 
bjuice's Avatar
 
Join Date: Apr 2003
Location: Greenville s.c.
Posts: 3,239
Default

you can best believe the tranny is moving "flexing" or it would not crack...the cheapest way i can tell you to fix this is a MID-PLATE..this is why they make these plates..to stop the tranny/motor from moving in that area.....a mid plate should stop the cracking.

Brian
__________________
Bjuice..

"I'M YOUR HUCKLEBERRY ! "
bjuice is offline  
Old 01-27-2008, 09:22 AM
  #16  
DaKoTaKiD
Junior Member
SHOW GUEST
 
Join Date: Sep 2006
Posts: 3
Default

bent driveshaft, or excessive runout.
DaKoTaKiD is offline  
Old 01-29-2008, 05:05 PM
  #17  
kiesel
Junior Member
SHOW GUEST
 
Join Date: Mar 2005
Posts: 4
Default

there are three huge clutches are lugged to the case on a th350. if you have it set up to shift hard this will cause the th350 to breack the case. This is the only transmission that uses that style clutch instead of a second gear band. It does have a second gear band but only for engine braking. hope this helps.

SnK Performance
REAL WORLD POWER
kiesel is offline  
Old 02-22-2008, 06:58 AM
  #18  
qiksix
Member
CRAFTSMAN
 
Join Date: Apr 2006
Posts: 62
Default

i'm having the same problem but at the other end, the cone cracks. trans has been in same car for 8 years no changes, cracked 2 since being refreshed.
qiksix is offline  
Old 03-07-2008, 07:40 AM
  #19  
sgblazer2
Junior Member
APPRENTICE
Thread Starter
 
Join Date: Nov 2007
Posts: 14
Default

I have put a 8pt. rollcage, traction bars, motor plate, and pinion angle shims on the blazer and the problem is fixed!! Iam no longer breaking the bellhousing and I picked up a half sec. Thanks for the help!
sgblazer2 is offline  
Old 03-07-2008, 05:21 PM
  #20  
jmarksdragster
Senior Member
RACING JUNKIE
 
jmarksdragster's Avatar
 
Join Date: Jul 2007
Location: Florida
Posts: 635
Default

Good job!! It's surprising what tying the car together will do with ET and you'll find that consistancy will improve as well. 8) 8) 8)
jmarksdragster is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service