zz502? crate problems

Old 11-08-2021, 05:04 AM
  #1  
GSI_103183640487218328641
Junior Member
SHOW GUEST
Thread Starter
 
Join Date: Nov 2021
Posts: 7
Default zz502? crate problems

4 miles on new crate motor and rocker arm nuts backed off can,t wait to see what comes next .All the rocker ***** are galled.and looks like they are made of the powdered metal process .Chinese ? any Ideas this is the new zz502 deluxe engine also lots of dust in the pan when i pulled it to change it upon first arrival ,anyone experiance these problems.

Last edited by GSI_103183640487218328641; 11-08-2021 at 01:13 PM.
GSI_103183640487218328641 is offline  
Old 07-04-2023, 12:21 PM
  #2  
ssikolc
Junior Member
SHOW GUEST
 
Join Date: Dec 2021
Posts: 6
Default

Does anybody have any regrettable encounters first or secondhand, with the ZZ502? Over the top oil utilization, unfortunate workmanship, and so forth? I'm thinking about buying one and simply maintain that should get my work done. I will likely add a Holley C950 EFI to it. Stringently road use.
ssikolc is offline  
Old 01-30-2024, 04:30 AM
  #3  
Alexand
Junior Member
SHOW GUEST
 
Join Date: Jan 2024
Location: London
Posts: 7
Default

From what you've described, it's possible that the rocker arm nuts were not torqued to the correct specifications during assembly. You'll need to return them to the specifications outlined in the service manual. It's also a good idea to check if the threads are in good condition.
Alexand is offline  
Old 05-20-2024, 08:31 AM
  #4  
bongdalu6vip
Junior Member
SHOW GUEST
 
Join Date: May 2024
Posts: 1
Default

i like it and do you like it
bongdalu6vip is offline  
Old Yesterday, 08:48 PM
  #5  
moresteve
Junior Member
SHOW GUEST
 
Join Date: Jun 2024
Posts: 3
Default

Originally Posted by GSI_103183640487218328641 View Post
4 miles on new crate motor and rocker arm nuts backed off can,t wait to see what comes next .All the rocker ***** are galled.and looks like they are made of the powdered metal process .Chinese ? any Ideas this is the new zz502 deluxe engine also lots of dust in the pan when i pulled it to change it upon first arrival ,anyone experiance these problems.
Hello,
It sounds like your ZZ502 deluxe engine might have quality control issues. Contact the supplier or manufacturer immediately to report these defects and request a replacement or refund. Ensure any future engine purchases are from a reputable source to avoid similar problems.
moresteve is offline  
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -